# CVE-2022-35628: SQL Injection in typo3 extension "LUX - TYPO3 Marketing Automation"

> Attackers can execute arbitrary SQL commands via the lux extension in TYPO3, potentially reading or modifying database contents.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rpxg-hg79-h8q9

## What is CVE-2022-35628?

CVE-2022-35628 is a critical SQL injection vulnerability in n/a, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A SQL injection issue was discovered in the lux extension before 17.6.1, and 18.x through 24.x before 24.0.2, for TYPO3.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-35628?

4 open source packages ship an affected version, including in2code/lux. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `in2code/lux` | Packagist | All versions | 17.6.1 |
| `in2code/lux` | Packagist | All versions | 17.6.1 |
| `in2code/lux` | Packagist | From 18.0.0 | 24.0.2 |
| `in2code/lux` | Packagist | From 18.0.0 | 24.0.2 |

Products: In2code Living User Experience.

## How do I fix CVE-2022-35628?

Upgrade in2code/lux to a fixed version for your release line: 17.6.1 or 24.0.2.

## Is CVE-2022-35628 being exploited?

There is no known exploitation of CVE-2022-35628 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35628 and fix it if it is affected.

What it is: CVE-2022-35628 is a critical SQL injection vulnerability in n/a, published on 12 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35628 in the wild and no public exploit code.

Affected packages and fixed versions:
- in2code/lux (Packagist): affected all versions; fixed in 17.6.1
- in2code/lux (Packagist): affected all versions; fixed in 17.6.1
- in2code/lux (Packagist): affected from 18.0.0; fixed in 24.0.2
- in2code/lux (Packagist): affected from 18.0.0; fixed in 24.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35628/ (Markdown: https://insights.sbomify.com/CVE-2022-35628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35628
- OSV: https://osv.dev/vulnerability/CVE-2022-35628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35628/
Summaries are generated and may contain mistakes; the official description above is the record.
