CVE-2022-35649 Moodle PostScript Code Injection
Remote attackers can execute arbitrary code on Moodle sites using vulnerable GhostScript versions due to improper PostScript input validation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-35649?
CVE-2022-35649 is a critical code injection vulnerability in Fedoraproject Fedora, published on 25 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.
Which versions are affected by CVE-2022-35649?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.11 | 3.11.8 |
moodle/moodle Packagist | From 3.11 | 3.11.8 |
moodle/moodle Packagist | From 3.9 | 3.9.15 |
moodle/moodle Packagist | From 3.9 | 3.9.15 |
moodle/moodle Packagist | From 4.0 | 4.0.2 |
moodle/moodle Packagist | From 4.0 | 4.0.2 |
1 more packages
moodle Bitnami | From 3.9.0 | 3.9.15, 3.11.8, 4.0.2 |
Products include Fedoraproject Fedora, Moodle Moodle.
How do I fix CVE-2022-35649?
Upgrade moodle/moodle to a fixed version for your release line: 3.11.8, 3.9.15 or 4.0.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-35649 being exploited?
There is no known exploitation of CVE-2022-35649 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as BIT-moodle-2022-35649, GHSA-xp2f-9mx3-3c6p, UBUNTU-CVE-2022-35649.