{"answers":{"affected":"7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-35649 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.11.8, 3.9.15 or 4.0.2.","what":"CVE-2022-35649 is a critical code injection vulnerability in Fedoraproject Fedora, published on 25 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-35649 and fix it if it is affected.\n\nWhat it is: CVE-2022-35649 is a critical code injection vulnerability in Fedoraproject Fedora, published on 25 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-35649 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.8\n- moodle/moodle (Packagist): affected from 3.11; fixed in 3.11.8\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.15\n- moodle/moodle (Packagist): affected from 3.9; fixed in 3.9.15\n- moodle/moodle (Packagist): affected from 4.0; fixed in 4.0.2\n- moodle/moodle (Packagist): affected from 4.0; fixed in 4.0.2\n- moodle (Bitnami): affected from 3.9.0; fixed in 3.9.15, 3.11.8, 4.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35649/ (Markdown: https://insights.sbomify.com/CVE-2022-35649/index.md)","id":"CVE-2022-35649","markdown":"https://insights.sbomify.com/CVE-2022-35649/index.md","name":"CVE-2022-35649","record":{"aliases":["BIT-moodle-2022-35649","GHSA-xp2f-9mx3-3c6p","UBUNTU-CVE-2022-35649"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Moodle LMS","requires_auth":"none","summary":"Remote attackers can execute arbitrary code on Moodle sites using vulnerable GhostScript versions due to improper PostScript input validation.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"moodle","vendor":"moodle"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":"2023-03-06","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2023-03-06T10:09:59Z","kind":"github_poc","ref":"https://github.com/antoinenguyen-09/CVE-2022-35649","stars":0,"title":"Payload Generator and Detailed Analysis about CVE-2022-35649 "}],"tier":"poc_unverified"},"has_fix":true,"headline":"Moodle PostScript Code Injection","id":"CVE-2022-35649","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora","moodle:moodle"],"type":"code_injection","year":"2022"},"n_packages":7,"n_references":5,"next":{"headline":"Moodle Arbitrary file read when importing lesson questions","id":"CVE-2022-35650"},"packages":[{"ecosystem":"Bitnami","fixed":["3.9.15","3.11.8","4.0.2"],"introduced":["3.9.0","3.11.0","4.0.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2022-35649"},{"ecosystem":"Packagist","fixed":["3.11.8"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-xp2f-9mx3-3c6p"},{"ecosystem":"Packagist","fixed":["3.11.8"],"introduced":["3.11"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-xp2f-9mx3-3c6p"},{"ecosystem":"Packagist","fixed":["3.9.15"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-xp2f-9mx3-3c6p"},{"ecosystem":"Packagist","fixed":["3.9.15"],"introduced":["3.9"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-xp2f-9mx3-3c6p"},{"ecosystem":"Packagist","fixed":["4.0.2"],"introduced":["4.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-xp2f-9mx3-3c6p"},{"ecosystem":"Packagist","fixed":["4.0.2"],"introduced":["4.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-xp2f-9mx3-3c6p"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2022-35648"},"products":["Moodle"],"published":"2022-07-25","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code on Moodle sites using vulnerable GhostScript versions due to improper PostScript input validation.","url":"https://insights.sbomify.com/CVE-2022-35649/"}