CVE-2022-35692 Adobe Commerce Improper Access Control Security feature bypass
An attacker can bypass security controls to leak minor account details of other users in Adobe Commerce without user interaction.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-35692?
CVE-2022-35692 is a medium-severity missing authorization vulnerability in Adobe Commerce, published on 19 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to leak minor information of another user's account detials. Exploitation of this issue does not require user interaction.
Weakness: CWE-863
Which versions are affected by CVE-2022-35692?
8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | From 2.3.7-p1 | 2.3.7-p4 |
magento/community-edition Packagist | From 2.3.7-p1 | 2.3.7-p4 |
magento/community-edition Packagist | From 2.4.3-p1 | 2.4.3-p3 |
magento/community-edition Packagist | From 2.4.3-p1 | 2.4.3-p3 |
2 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Adobe Commerce, Adobe Magento Commerce.
How do I fix CVE-2022-35692?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p4 or 2.4.3-p3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-35692 being exploited?
There is no known exploitation of CVE-2022-35692 in the wild and no public exploit code.
Other vulnerabilities in Adobe Commerce
- CVE-2026-75650 Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine
- CVE-2024-34102 Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE)
- CVE-2022-24086 Adobe Commerce and Magento Open Source Improper Input Validation
- CVE-2026-48356 Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type
- CVE-2026-71362 Adobe Commerce and Magento Incorrect Authorization Vulnerability
Sources
Also known as GHSA-gm4m-9rm8-7rxj.