{"answers":{"affected":"2 open source packages ship an affected version, including com.adobe.cq:core.wcm.components.core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-35697 in the wild and no public exploit code.","fix":"Upgrade com.adobe.cq:core.wcm.components.core to 2.20.8 or later.","what":"CVE-2022-35697 is a medium-severity cross-site scripting vulnerability in Adobe Experience Manager, published on 9 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-35697 and fix it if it is affected.\n\nWhat it is: CVE-2022-35697 is a medium-severity cross-site scripting vulnerability in Adobe Experience Manager, published on 9 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-35697 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.adobe.cq:core.wcm.components.core (Maven): affected all versions; fixed in 2.20.8\n- com.adobe.cq:core.wcm.components.core (Maven): affected all versions; fixed in 2.20.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35697/ (Markdown: https://insights.sbomify.com/CVE-2022-35697/index.md)","id":"CVE-2022-35697","markdown":"https://insights.sbomify.com/CVE-2022-35697/index.md","name":"CVE-2022-35697","record":{"aliases":["GHSA-qcgc-6q86-7x2p"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Adobe Experience Manager","requires_auth":"low_privilege","summary":"Reflected XSS in Adobe Experience Manager allows attackers to execute malicious scripts in victim browsers via crafted URLs, requiring low author privileges.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"web_content_management_core_components","vendor":"adobe"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Adobe Experience Manager Core Components version 2.20.6 (and earlier) is affected by a reflected Cross-Site Scripting (XSS) vulnerability. If an attacker is able to convince a victim to visit a URL referencing a vulnerable page, malicious JavaScript content may be executed within the context of the victim's browser. Exploitation of this issue requires a low author privilege access.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AEM File Upload Security Issue leading to RXSS","id":"CVE-2022-35697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Adobe Commerce Stored XSS Arbitrary code execution","id":"CVE-2022-35698"},"packages":[{"ecosystem":"Maven","fixed":["2.20.8"],"introduced":["0"],"last_affected":[],"package":"com.adobe.cq:core.wcm.components.core","purl":null,"source":"GHSA-qcgc-6q86-7x2p"},{"ecosystem":"Maven","fixed":["2.20.8"],"introduced":["0"],"last_affected":[],"package":"com.adobe.cq:core.wcm.components.core","purl":"pkg:maven/com.adobe.cq/core.wcm.components.core","source":"GHSA-qcgc-6q86-7x2p"}],"prev":{"headline":"AEM Reflected XSS Arbitrary code execution","id":"CVE-2022-35696"},"products":["Experience Manager"],"published":"2022-08-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["Adobe"]},"summary":"Reflected XSS in Adobe Experience Manager allows attackers to execute malicious scripts in victim browsers via crafted URLs, requiring low author privileges.","url":"https://insights.sbomify.com/CVE-2022-35697/"}