# CVE-2022-35697: AEM File Upload Security Issue leading to RXSS

> Reflected XSS in Adobe Experience Manager allows attackers to execute malicious scripts in victim browsers via crafted URLs, requiring low author privileges.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-qcgc-6q86-7x2p

## What is CVE-2022-35697?

CVE-2022-35697 is a medium-severity cross-site scripting vulnerability in Adobe Experience Manager, published on 9 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Adobe Experience Manager Core Components version 2.20.6 (and earlier) is affected by a reflected Cross-Site Scripting (XSS) vulnerability. If an attacker is able to convince a victim to visit a URL referencing a vulnerable page, malicious JavaScript content may be executed within the context of the victim's browser. Exploitation of this issue requires a low author privilege access.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-35697?

2 open source packages ship an affected version, including com.adobe.cq:core.wcm.components.core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.adobe.cq:core.wcm.components.core` | Maven | All versions | 2.20.8 |
| `com.adobe.cq:core.wcm.components.core` | Maven | All versions | 2.20.8 |

Products: Adobe Web Content Management Core Components.

## How do I fix CVE-2022-35697?

Upgrade com.adobe.cq:core.wcm.components.core to 2.20.8 or later.

## Is CVE-2022-35697 being exploited?

There is no known exploitation of CVE-2022-35697 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35697 and fix it if it is affected.

What it is: CVE-2022-35697 is a medium-severity cross-site scripting vulnerability in Adobe Experience Manager, published on 9 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-35697 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.adobe.cq:core.wcm.components.core (Maven): affected all versions; fixed in 2.20.8
- com.adobe.cq:core.wcm.components.core (Maven): affected all versions; fixed in 2.20.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35697/ (Markdown: https://insights.sbomify.com/CVE-2022-35697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35697
- OSV: https://osv.dev/vulnerability/CVE-2022-35697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35697/
Summaries are generated and may contain mistakes; the official description above is the record.
