{"answers":{"affected":"1 open source package ship an affected version, including gitlab. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3573 exists.","fix":"Upgrade gitlab to a fixed version for your release line: 15.5.7, 15.6.4 or 15.7.2.","what":"CVE-2022-3573 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 12 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-3573 and fix it if it is affected.\n\nWhat it is: CVE-2022-3573 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 12 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3573 exists.\n\nAffected packages and fixed versions:\n- gitlab (Bitnami): affected from 15.4.0; fixed in 15.5.7, 15.6.4, 15.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3573/ (Markdown: https://insights.sbomify.com/CVE-2022-3573/index.md)","id":"CVE-2022-3573","markdown":"https://insights.sbomify.com/CVE-2022-3573/index.md","name":"CVE-2022-3573","record":{"aliases":["BIT-gitlab-2022-3573","GHSA-jwcg-x754-2vpg","UBUNTU-CVE-2022-3573"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"GitLab","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript on self-hosted GitLab instances lacking strict CSP via improper filtering in the wiki changes page.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitLab","cpe":[{"product":"drive_composer","vendor":"abb"},{"product":"gitlab","vendor":"gitlab"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.4 before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. Due to the improper filtering of query parameters in the wiki changes page, an attacker can execute arbitrary JavaScript on the self-hosted instances running without strict CSP.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site scripting in GitLab","id":"CVE-2022-3573","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"gitlab:gitlab","products":["gitlab:gitlab"],"type":"xss","year":"2022"},"n_packages":1,"n_references":3,"next":{"headline":"WPForms Pro \u003c 1.7.7 - CSV Injection","id":"CVE-2022-3574"},"packages":[{"ecosystem":"Bitnami","fixed":["15.5.7","15.6.4","15.7.2"],"introduced":["15.4.0","15.6.0","15.7.0"],"last_affected":[],"package":"gitlab","purl":"pkg:bitnami/gitlab","source":"BIT-gitlab-2022-3573"}],"prev":{"headline":"Cross-site scripting in GitLab","id":"CVE-2022-3572"},"products":["GitLab"],"published":"2023-01-12","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-08","vendors":["GitLab"]},"summary":"Attackers can execute arbitrary JavaScript on self-hosted GitLab instances lacking strict CSP via improper filtering in the wiki changes page.","url":"https://insights.sbomify.com/CVE-2022-3573/"}