{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-35861 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-35861 is a high-severity path traversal vulnerability in n/a, published on 17 Jul 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-35861 and fix it if it is affected.\n\nWhat it is: CVE-2022-35861 is a high-severity path traversal vulnerability in n/a, published on 17 Jul 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-35861 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35861/ (Markdown: https://insights.sbomify.com/CVE-2022-35861/index.md)","id":"CVE-2022-35861","markdown":"https://insights.sbomify.com/CVE-2022-35861/index.md","name":"CVE-2022-35861","record":{"aliases":["GHSA-7rf7-7xf5-v9v3","openSUSE-SU-2022:10183-1","openSUSE-SU-2024:12200-1"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python version manager","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges and execute arbitrary code by crafting a malicious .python-version file in the current directory.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pyenv","vendor":"pyenv"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"pyenv 1.2.24 through 2.3.2 allows local users to gain privileges via a .python-version file in the current working directory. An attacker can craft a Python version string in .python-version to execute shims under their control. (Shims are executables that pass a command along to a specific version of pyenv. The version string is used to construct the path to the command, and there is no validation of whether the version specified is a valid version. Thus, relative path traversal can occur.)","ecosystems":["SUSE:Package Hub 15 SP4","openSUSE:Leap 15.4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path traversal in n/a","id":"CVE-2022-35861","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"SQL injection in Track-It!","id":"CVE-2022-35864"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["2.3.5-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"pyenv","purl":"pkg:rpm/suse/pyenv\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2022:10183-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["2.3.5-bp154.2.3.1"],"introduced":["0"],"last_affected":[],"package":"pyenv","purl":"pkg:rpm/opensuse/pyenv\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2022:10183-1"}],"prev":{"headline":"Missing AES encryption in Corsair K63 Wireless 3.1.3 allows physically proximate attackers to inject and sniff keystrokes via 2.4 GHz radio transmissions.","id":"CVE-2022-35860"},"products":["n/a"],"published":"2022-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Local attackers can escalate privileges and execute arbitrary code by crafting a malicious .python-version file in the current directory.","url":"https://insights.sbomify.com/CVE-2022-35861/"}