# CVE-2022-3590: WP <= 6.1.1 - Unauthenticated Blind SSRF via DNS Rebinding

> Unauthenticated attackers can exploit a race condition in WordPress pingbacks to perform blind SSRF and access internal network resources.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 21 Apr 2025
- **Also known as:** BIT-wordpress-2022-3590, BIT-wordpress-multisite-2022-3590, DEBIAN-CVE-2022-3590, GHSA-mjj5-7gmf-mfjx, UBUNTU-CVE-2022-3590

## What is CVE-2022-3590?

CVE-2022-3590 is a medium-severity server-side request forgery vulnerability in Wordpress Wordpress, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WordPress is affected by an unauthenticated blind SSRF in the pingback feature. Because of a TOCTOU race condition between the validation checks and the HTTP request, attackers can reach internal hosts that are explicitly forbidden.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2022-3590?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 4.1.0 | 4.1.1, 6.1.2 |
| `wordpress-multisite` | Bitnami | From 4.1.0 | 4.1.1, 6.1.2 |

Products: Wordpress Wordpress.

## How do I fix CVE-2022-3590?

Upgrade wordpress to a fixed version for your release line: 4.1.1 or 6.1.2.

## Is CVE-2022-3590 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3590 exists.

Public exploit code:

-  This repository contains a Python script that checks WordPress websites for the CVE-2022-3590 vulnerability, which exploits an unauthenticated blind Server-Side Request Forgery (SSRF) in the WordPress pingback feature. (github_poc): https://github.com/hxlxmj/CVE-2022-3590-WordPress-Vulnerability-Scanner
- https://github.com/huynhvanphuc/CVE-2022-3590-WordPress-Vulnerability-Scanner (github_poc): https://github.com/huynhvanphuc/CVE-2022-3590-WordPress-Vulnerability-Scanner
- Based on CVE-2022-3590, WordPress <= 6.9.1 - Unauthenticated Blind SSRF via XML-RPC Pingback Discovery proof of concept (PoC) (github_poc): https://github.com/TJouleL/WordPress-6.9.1-Blind-SSRF
- WordPress <= 6.2 - Server Side Request Forgery (nuclei): http/cves/2022/CVE-2022-3590.yaml

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3590 and fix it if it is affected.

What it is: CVE-2022-3590 is a medium-severity server-side request forgery vulnerability in Wordpress Wordpress, published on 14 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3590 exists.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 4.1.0; fixed in 4.1.1, 6.1.2
- wordpress-multisite (Bitnami): affected from 4.1.0; fixed in 4.1.1, 6.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3590/ (Markdown: https://insights.sbomify.com/CVE-2022-3590/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3590
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3590
- OSV: https://osv.dev/vulnerability/CVE-2022-3590

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3590/
Summaries are generated and may contain mistakes; the official description above is the record.
