CVE-2022-35912 Grails framework Remote Code Execution via Data Binding
Remote attackers can execute arbitrary code via data binding in Grails when specific Java 8 configurations are active.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-35912?
CVE-2022-35912 is a critical code injection vulnerability in n/a, published on 19 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at least when certain Java 8 configurations are used), data binding allows a remote attacker to execute code by gaining access to the class loader.
Which versions are affected by CVE-2022-35912?
8 open source packages ship an affected version, including org.grails:grails-databinding. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.grails:grails-databinding Maven | From 3.3.10 | 3.3.15 |
org.grails:grails-databinding Maven | From 3.3.10 | 3.3.15 |
org.grails:grails-databinding Maven | From 4.0.0 | 4.1.1 |
org.grails:grails-databinding Maven | From 4.0.0 | 4.1.1 |
org.grails:grails-databinding Maven | From 5.0.0 | 5.1.9 |
org.grails:grails-databinding Maven | From 5.0.0 | 5.1.9 |
2 more packages
org.grails:grails-databinding Maven | From 5.2.0 | 5.2.1 |
org.grails:grails-databinding Maven | From 5.2.0 | 5.2.1 |
Products include Grails Grails.
How do I fix CVE-2022-35912?
Upgrade org.grails:grails-databinding to a fixed version for your release line: 3.3.15, 4.1.1, 5.1.9 or 5.2.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-35912 being exploited?
There is no known exploitation of CVE-2022-35912 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-6rh6-x8ww-9h97.