{"answers":{"affected":"8 open source packages ship an affected version, including org.grails:grails-databinding. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-35912 in the wild and no public exploit code.","fix":"Upgrade org.grails:grails-databinding to a fixed version for your release line: 3.3.15, 4.1.1, 5.1.9 or 5.2.1.","what":"CVE-2022-35912 is a critical code injection vulnerability in n/a, published on 19 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-35912 and fix it if it is affected.\n\nWhat it is: CVE-2022-35912 is a critical code injection vulnerability in n/a, published on 19 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-35912 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.grails:grails-databinding (Maven): affected from 3.3.10; fixed in 3.3.15\n- org.grails:grails-databinding (Maven): affected from 3.3.10; fixed in 3.3.15\n- org.grails:grails-databinding (Maven): affected from 4.0.0; fixed in 4.1.1\n- org.grails:grails-databinding (Maven): affected from 4.0.0; fixed in 4.1.1\n- org.grails:grails-databinding (Maven): affected from 5.0.0; fixed in 5.1.9\n- org.grails:grails-databinding (Maven): affected from 5.0.0; fixed in 5.1.9\n- org.grails:grails-databinding (Maven): affected from 5.2.0; fixed in 5.2.1\n- org.grails:grails-databinding (Maven): affected from 5.2.0; fixed in 5.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35912/ (Markdown: https://insights.sbomify.com/CVE-2022-35912/index.md)","id":"CVE-2022-35912","markdown":"https://insights.sbomify.com/CVE-2022-35912/index.md","name":"CVE-2022-35912","record":{"aliases":["GHSA-6rh6-x8ww-9h97"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Grails data binding library","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via data binding in Grails when specific Java 8 configurations are active.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"grails","vendor":"grails"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at least when certain Java 8 configurations are used), data binding allows a remote attacker to execute code by gaining access to the class loader.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Grails framework Remote Code Execution via Data Binding","id":"CVE-2022-35912","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":8,"n_references":4,"next":{"headline":"Denial of service in n/a","id":"CVE-2022-35913"},"packages":[{"ecosystem":"Maven","fixed":["3.3.15"],"introduced":["3.3.10"],"last_affected":[],"package":"org.grails:grails-databinding","purl":null,"source":"GHSA-6rh6-x8ww-9h97"},{"ecosystem":"Maven","fixed":["3.3.15"],"introduced":["3.3.10"],"last_affected":[],"package":"org.grails:grails-databinding","purl":"pkg:maven/org.grails/grails-databinding","source":"GHSA-6rh6-x8ww-9h97"},{"ecosystem":"Maven","fixed":["4.1.1"],"introduced":["4.0.0"],"last_affected":[],"package":"org.grails:grails-databinding","purl":null,"source":"GHSA-6rh6-x8ww-9h97"},{"ecosystem":"Maven","fixed":["4.1.1"],"introduced":["4.0.0"],"last_affected":[],"package":"org.grails:grails-databinding","purl":"pkg:maven/org.grails/grails-databinding","source":"GHSA-6rh6-x8ww-9h97"},{"ecosystem":"Maven","fixed":["5.1.9"],"introduced":["5.0.0"],"last_affected":[],"package":"org.grails:grails-databinding","purl":null,"source":"GHSA-6rh6-x8ww-9h97"},{"ecosystem":"Maven","fixed":["5.1.9"],"introduced":["5.0.0"],"last_affected":[],"package":"org.grails:grails-databinding","purl":"pkg:maven/org.grails/grails-databinding","source":"GHSA-6rh6-x8ww-9h97"},{"ecosystem":"Maven","fixed":["5.2.1"],"introduced":["5.2.0"],"last_affected":[],"package":"org.grails:grails-databinding","purl":null,"source":"GHSA-6rh6-x8ww-9h97"},{"ecosystem":"Maven","fixed":["5.2.1"],"introduced":["5.2.0"],"last_affected":[],"package":"org.grails:grails-databinding","purl":"pkg:maven/org.grails/grails-databinding","source":"GHSA-6rh6-x8ww-9h97"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2022-35911"},"products":["n/a"],"published":"2022-07-19","related":[{"cvss_score":8.1,"headline":"Incorrect Resource Transfer Between Spheres in Grails","id":"CVE-2019-12728","kev_date_added":null,"published":"2019-06-04"},{"cvss_score":6.5,"headline":"Grails® data binding causes JVM crash and/or DoS","id":"CVE-2023-46131","kev_date_added":null,"published":"2023-12-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via data binding in Grails when specific Java 8 configurations are active.","url":"https://insights.sbomify.com/CVE-2022-35912/"}