# CVE-2022-35915: Unbounded gas consumption in @openzeppelin/contracts

> Attackers can cause unbounded gas consumption in smart contracts using OpenZeppelin's EIP-165 interface checks, leading to denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-7grf-83vw-6f5x

## What is CVE-2022-35915?

CVE-2022-35915 is a medium-severity denial of service vulnerability in openzeppelin-contracts, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for secure smart contract development. The target contract of an EIP-165 `supportsInterface` query can cause unbounded gas consumption by returning a lot of data, while it is generally assumed that this operation has a bounded cost. The issue has been fixed in v4.7.2. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-35915?

8 open source packages ship an affected version, including @openzeppelin/contracts, @openzeppelin/contracts-upgradeable and openzeppelin-eth. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 2.0.0 | 4.7.2 |
| `@openzeppelin/contracts` | npm | From 2.0.0 | 4.7.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 3.2.0 | 4.7.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 3.2.0 | 4.7.2 |
| `openzeppelin-eth` | npm | From 2.0.0 to 2.2.0 | None |
| `openzeppelin-eth` | npm | From 2.0.0 to 2.2.0 | None |
| `openzeppelin-solidity` | npm | From 2.0.0 to 4.6.0 | None |
| `openzeppelin-solidity` | npm | From 2.0.0 to 4.6.0 | None |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable, Openzeppelin Openzeppelin-Eth, Openzeppelin Openzeppelin-Solidity.

## How do I fix CVE-2022-35915?

Upgrade @openzeppelin/contracts to 4.7.2 or later.

## Is CVE-2022-35915 being exploited?

There is no known exploitation of CVE-2022-35915 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35915 and fix it if it is affected.

What it is: CVE-2022-35915 is a medium-severity denial of service vulnerability in openzeppelin-contracts, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35915 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 2.0.0; fixed in 4.7.2
- @openzeppelin/contracts (npm): affected from 2.0.0; fixed in 4.7.2
- @openzeppelin/contracts-upgradeable (npm): affected from 3.2.0; fixed in 4.7.2
- @openzeppelin/contracts-upgradeable (npm): affected from 3.2.0; fixed in 4.7.2
- openzeppelin-eth (npm): affected from 2.0.0 up to 2.2.0; no fix listed
- openzeppelin-eth (npm): affected from 2.0.0 up to 2.2.0; no fix listed
- openzeppelin-solidity (npm): affected from 2.0.0 up to 4.6.0; no fix listed
- openzeppelin-solidity (npm): affected from 2.0.0 up to 4.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35915/ (Markdown: https://insights.sbomify.com/CVE-2022-35915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35915
- OSV: https://osv.dev/vulnerability/CVE-2022-35915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35915/
Summaries are generated and may contain mistakes; the official description above is the record.
