# CVE-2022-35916: Cross chain utilities for Arbitrum L2 see EOA calls as cross chain calls

> Smart contracts using OpenZeppelin Arbitrum L2 utilities incorrectly treat direct EOA calls as cross-chain, potentially bypassing security checks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-9j3m-g383-29qr

## What is CVE-2022-35916?

CVE-2022-35916 is a medium-severity vulnerability in openzeppelin-contracts, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for secure smart contract development. Contracts using the cross chain utilities for Arbitrum L2, `CrossChainEnabledArbitrumL2` or `LibArbitrumL2`, will classify direct interactions of externally owned accounts (EOAs) as cross chain calls, even though they are not started on L1. This issue has been patched in v4.7.2. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-669 (Incorrect Resource Transfer Between Spheres)

## Which versions are affected by CVE-2022-35916?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.6.0 | 4.7.2 |
| `@openzeppelin/contracts` | npm | From 4.6.0 | 4.7.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.6.0 | 4.7.2 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.6.0 | 4.7.2 |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

## How do I fix CVE-2022-35916?

Upgrade @openzeppelin/contracts to 4.7.2 or later.

## Is CVE-2022-35916 being exploited?

There is no known exploitation of CVE-2022-35916 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35916 and fix it if it is affected.

What it is: CVE-2022-35916 is a medium-severity vulnerability in openzeppelin-contracts, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35916 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.6.0; fixed in 4.7.2
- @openzeppelin/contracts (npm): affected from 4.6.0; fixed in 4.7.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.6.0; fixed in 4.7.2
- @openzeppelin/contracts-upgradeable (npm): affected from 4.6.0; fixed in 4.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35916/ (Markdown: https://insights.sbomify.com/CVE-2022-35916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35916
- OSV: https://osv.dev/vulnerability/CVE-2022-35916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35916/
Summaries are generated and may contain mistakes; the official description above is the record.
