# CVE-2022-35917: Weakness in Transfer Validation Logic in @solana/pay

> Attackers can bypass transfer validation logic in the Solana Pay SDK, potentially allowing unauthorized or incorrect transaction processing.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-j47c-j42c-mwqq

## What is CVE-2022-35917?

CVE-2022-35917 is a medium-severity vulnerability in solana-labs solana-pay, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Solana Pay is a protocol and set of reference implementations that enable developers to incorporate decentralized payments into their apps and services. When a Solana Pay transaction is located using a reference key, it may be checked to represent a transfer of the desired amount to the recipient, using the supplied `validateTransfer` function. An edge case regarding this mechanism could cause the validation logic to validate multiple transfers. This issue has been patched as of version `0.2.1`. Users of the Solana Pay SDK should upgrade to it. There are no known workarounds for this issue.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation)

## Which versions are affected by CVE-2022-35917?

2 open source packages ship an affected version, including @solana/pay. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@solana/pay` | npm | All versions | 0.2.1 |
| `@solana/pay` | npm | All versions | 0.2.1 |

Products: Solanalabs Pay.

## How do I fix CVE-2022-35917?

Upgrade @solana/pay to 0.2.1 or later.

## Is CVE-2022-35917 being exploited?

There is no known exploitation of CVE-2022-35917 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35917 and fix it if it is affected.

What it is: CVE-2022-35917 is a medium-severity vulnerability in solana-labs solana-pay, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35917 in the wild and no public exploit code.

Affected packages and fixed versions:
- @solana/pay (npm): affected all versions; fixed in 0.2.1
- @solana/pay (npm): affected all versions; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35917/ (Markdown: https://insights.sbomify.com/CVE-2022-35917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35917
- OSV: https://osv.dev/vulnerability/CVE-2022-35917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35917/
Summaries are generated and may contain mistakes; the official description above is the record.
