CVE-2022-35921 User preference to prevent private discussions not respected in fof/byobu
Attackers can access private discussions despite user settings, exposing sensitive data in Flarum forums using the Byobu extension.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-35921?
CVE-2022-35921 is a low-severity missing authorization vulnerability in FriendsOfFlarum byobu, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
fof/byobu is a private discussions extension for Flarum forum. Affected versions were found to not respect private discussion disablement by users. Users of Byobu should update the extension to version 1.1.7, where this has been patched. Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed. There are no workarounds for this issue.
Which versions are affected by CVE-2022-35921?
2 open source packages ship an affected version, including fof/byobu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fof/byobu Packagist | From 0.3.0-beta.2 | 1.1.7 |
fof/byobu Packagist | From 0.3.0-beta.2 | 1.1.7 |
Products include Friendsofflarum Byobu.
How do I fix CVE-2022-35921?
Upgrade fof/byobu to 1.1.7 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-35921 being exploited?
There is no known exploitation of CVE-2022-35921 in the wild and no public exploit code.
Sources
Also known as GHSA-6gjm-6wj6-4px5.