{"answers":{"affected":"2 open source packages ship an affected version, including fof/byobu. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-35921 in the wild and no public exploit code.","fix":"Upgrade fof/byobu to 1.1.7 or later.","what":"CVE-2022-35921 is a low-severity missing authorization vulnerability in FriendsOfFlarum byobu, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-35921 and fix it if it is affected.\n\nWhat it is: CVE-2022-35921 is a low-severity missing authorization vulnerability in FriendsOfFlarum byobu, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-35921 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fof/byobu (Packagist): affected from 0.3.0-beta.2; fixed in 1.1.7\n- fof/byobu (Packagist): affected from 0.3.0-beta.2; fixed in 1.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35921/ (Markdown: https://insights.sbomify.com/CVE-2022-35921/index.md)","id":"CVE-2022-35921","markdown":"https://insights.sbomify.com/CVE-2022-35921/index.md","name":"CVE-2022-35921","record":{"aliases":["GHSA-6gjm-6wj6-4px5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Flarum forum plugin","requires_auth":"low_privilege","summary":"Attackers can access private discussions despite user settings, exposing sensitive data in Flarum forums using the Byobu extension.","user_interaction":"required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"byobu","vendor":"friendsofflarum"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"fof/byobu is a private discussions extension for Flarum forum. Affected versions were found to not respect private discussion disablement by users. Users of Byobu should update the extension to version 1.1.7, where this has been patched. Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed. There are no workarounds for this issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"User preference to prevent private discussions not respected in fof/byobu","id":"CVE-2022-35921","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Memory allocation based on untrusted length in rust-websocket","id":"CVE-2022-35922"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.7"],"introduced":["0.3.0-beta.2"],"last_affected":[],"package":"fof/byobu","purl":null,"source":"GHSA-6gjm-6wj6-4px5"},{"ecosystem":"Packagist","fixed":["1.1.7"],"introduced":["0.3.0-beta.2"],"last_affected":[],"package":"fof/byobu","purl":"pkg:composer/fof/byobu","source":"GHSA-6gjm-6wj6-4px5"}],"prev":{"headline":"Improper Limitation of a Pathname to a Restricted Directory in sanic","id":"CVE-2022-35920"},"products":["byobu"],"published":"2022-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["FriendsOfFlarum"]},"summary":"Attackers can access private discussions despite user settings, exposing sensitive data in Flarum forums using the Byobu extension.","url":"https://insights.sbomify.com/CVE-2022-35921/"}