# CVE-2022-35921: User preference to prevent private discussions not respected in fof/byobu

> Attackers can access private discussions despite user settings, exposing sensitive data in Flarum forums using the Byobu extension.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-6gjm-6wj6-4px5

## What is CVE-2022-35921?

CVE-2022-35921 is a low-severity missing authorization vulnerability in FriendsOfFlarum byobu, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

fof/byobu is a private discussions extension for Flarum forum. Affected versions were found to not respect private discussion disablement by users. Users of Byobu should update the extension to version 1.1.7, where this has been patched. Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed. There are no workarounds for this issue.

Weakness: CWE-863 (Incorrect Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-35921?

2 open source packages ship an affected version, including fof/byobu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fof/byobu` | Packagist | From 0.3.0-beta.2 | 1.1.7 |
| `fof/byobu` | Packagist | From 0.3.0-beta.2 | 1.1.7 |

Products: Friendsofflarum Byobu.

## How do I fix CVE-2022-35921?

Upgrade fof/byobu to 1.1.7 or later.

## Is CVE-2022-35921 being exploited?

There is no known exploitation of CVE-2022-35921 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35921 and fix it if it is affected.

What it is: CVE-2022-35921 is a low-severity missing authorization vulnerability in FriendsOfFlarum byobu, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-35921 in the wild and no public exploit code.

Affected packages and fixed versions:
- fof/byobu (Packagist): affected from 0.3.0-beta.2; fixed in 1.1.7
- fof/byobu (Packagist): affected from 0.3.0-beta.2; fixed in 1.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35921/ (Markdown: https://insights.sbomify.com/CVE-2022-35921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35921
- OSV: https://osv.dev/vulnerability/CVE-2022-35921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35921/
Summaries are generated and may contain mistakes; the official description above is the record.
