{"answers":{"affected":"3 open source packages ship an affected version, including websocket. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-35922 in the wild and no public exploit code.","fix":"Upgrade websocket to 0.26.5 or later.","what":"CVE-2022-35922 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-35922 and fix it if it is affected.\n\nWhat it is: CVE-2022-35922 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-35922 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- websocket (crates.io): affected all versions; fixed in 0.26.5\n- websocket (crates.io): affected all versions; fixed in 0.26.5\n- websocket (crates.io): affected from 0.0.0-0; fixed in 0.26.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35922/ (Markdown: https://insights.sbomify.com/CVE-2022-35922/index.md)","id":"CVE-2022-35922","markdown":"https://insights.sbomify.com/CVE-2022-35922/index.md","name":"CVE-2022-35922","record":{"aliases":["GHSA-qrjv-rf5q-qpxc","RUSTSEC-2022-0035"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust WebSocket library","requires_auth":"none","summary":"Untrusted WebSocket frames can trigger out-of-memory crashes in the sync implementation, requiring an upgrade to the Rust library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"rust-websocket","vendor":"rust-websocket_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Rust-WebSocket is a WebSocket (RFC6455) library written in Rust. In versions prior to 0.26.5 untrusted websocket connections can cause an out-of-memory (OOM) process abort in a client or a server. The root cause of the issue is during dataframe parsing. Affected versions would allocate a buffer based on the declared dataframe size, which may come from an untrusted source. When `Vec::with_capacity` fails to allocate, the default Rust allocator will abort the current process, killing all threads. This affects only sync (non-Tokio) implementation. Async version also does not limit memory, but does not use `with_capacity`, so DoS can happen only when bytes for oversized dataframe or message actually got delivered by the attacker. The crashes are fixed in version 0.26.5 by imposing default dataframe size limits. Affected users are advised to update to this version. Users unable to upgrade are advised to filter websocket traffic externally or to only accept trusted traffic.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory allocation based on untrusted length in rust-websocket","id":"CVE-2022-35922","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"Inefficient Regular Expression Complexity in v8n","id":"CVE-2022-35923"},"packages":[{"ecosystem":"crates.io","fixed":["0.26.5"],"introduced":["0"],"last_affected":[],"package":"websocket","purl":null,"source":"GHSA-qrjv-rf5q-qpxc"},{"ecosystem":"crates.io","fixed":["0.26.5"],"introduced":["0"],"last_affected":[],"package":"websocket","purl":"pkg:cargo/websocket","source":"GHSA-qrjv-rf5q-qpxc"},{"ecosystem":"crates.io","fixed":["0.26.5"],"introduced":["0.0.0-0"],"last_affected":[],"package":"websocket","purl":"pkg:cargo/websocket","source":"RUSTSEC-2022-0035"}],"prev":{"headline":"User preference to prevent private discussions not respected in fof/byobu","id":"CVE-2022-35921"},"products":["rust-websocket"],"published":"2022-08-01","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["websockets-rs"]},"summary":"Untrusted WebSocket frames can trigger out-of-memory crashes in the sync implementation, requiring an upgrade to the Rust library.","url":"https://insights.sbomify.com/CVE-2022-35922/"}