# CVE-2022-35922: Memory allocation based on untrusted length in rust-websocket

> Untrusted WebSocket frames can trigger out-of-memory crashes in the sync implementation, requiring an upgrade to the Rust library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-qrjv-rf5q-qpxc, RUSTSEC-2022-0035

## What is CVE-2022-35922?

CVE-2022-35922 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rust-WebSocket is a WebSocket (RFC6455) library written in Rust. In versions prior to 0.26.5 untrusted websocket connections can cause an out-of-memory (OOM) process abort in a client or a server. The root cause of the issue is during dataframe parsing. Affected versions would allocate a buffer based on the declared dataframe size, which may come from an untrusted source. When `Vec::with_capacity` fails to allocate, the default Rust allocator will abort the current process, killing all threads. This affects only sync (non-Tokio) implementation. Async version also does not limit memory, but does not use `with_capacity`, so DoS can happen only when bytes for oversized dataframe or message actually got delivered by the attacker. The crashes are fixed in version 0.26.5 by imposing default dataframe size limits. Affected users are advised to update to this version. Users unable to upgrade are advised to filter websocket traffic externally or to only accept trusted traffic.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-35922?

3 open source packages ship an affected version, including websocket. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `websocket` | crates.io | All versions | 0.26.5 |
| `websocket` | crates.io | All versions | 0.26.5 |
| `websocket` | crates.io | From 0.0.0-0 | 0.26.5 |

Products: Fedoraproject Fedora, Rust-Websocket Project Rust-Websocket.

## How do I fix CVE-2022-35922?

Upgrade websocket to 0.26.5 or later.

## Is CVE-2022-35922 being exploited?

There is no known exploitation of CVE-2022-35922 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35922 and fix it if it is affected.

What it is: CVE-2022-35922 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35922 in the wild and no public exploit code.

Affected packages and fixed versions:
- websocket (crates.io): affected all versions; fixed in 0.26.5
- websocket (crates.io): affected all versions; fixed in 0.26.5
- websocket (crates.io): affected from 0.0.0-0; fixed in 0.26.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35922/ (Markdown: https://insights.sbomify.com/CVE-2022-35922/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35922
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35922
- OSV: https://osv.dev/vulnerability/CVE-2022-35922

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35922/
Summaries are generated and may contain mistakes; the official description above is the record.
