{"answers":{"affected":"2 open source packages ship an affected version, including v8n. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35923 exists.","fix":"Upgrade v8n to 1.5.1 or later.","what":"CVE-2022-35923 is a high-severity denial of service vulnerability in imbrn v8n, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-35923 and fix it if it is affected.\n\nWhat it is: CVE-2022-35923 is a high-severity denial of service vulnerability in imbrn v8n, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35923 exists.\n\nAffected packages and fixed versions:\n- v8n (npm): affected all versions; fixed in 1.5.1\n- v8n (npm): affected all versions; fixed in 1.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35923/ (Markdown: https://insights.sbomify.com/CVE-2022-35923/index.md)","id":"CVE-2022-35923","markdown":"https://insights.sbomify.com/CVE-2022-35923/index.md","name":"CVE-2022-35923","record":{"aliases":["GHSA-xrx9-gj26-5wx9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript validation library","requires_auth":"none","summary":"An attacker can cause a denial of service in the v8n validation library by exploiting inefficient regular expressions in lowercase and uppercase checks.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"v8n","vendor":"v8n_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"v8n is a javascript validation library. Versions of v8n prior to 1.5.1 were found to have an inefficient regular expression complexity in the `lowercase()` and `uppercase()` regex which could lead to a denial of service attack. In testing of the `lowercase()` function a payload of 'a' + 'a'.repeat(i) + 'A' with 32 leading characters took 29443 ms to execute. The same issue happens with uppercase(). Users are advised to upgrade. There are no known workarounds for this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Inefficient Regular Expression Complexity in v8n","id":"CVE-2022-35923","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Verification requests (magic link) sent to unwanted emails","id":"CVE-2022-35924"},"packages":[{"ecosystem":"npm","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"v8n","purl":null,"source":"GHSA-xrx9-gj26-5wx9"},{"ecosystem":"npm","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"v8n","purl":"pkg:npm/v8n","source":"GHSA-xrx9-gj26-5wx9"}],"prev":{"headline":"Memory allocation based on untrusted length in rust-websocket","id":"CVE-2022-35922"},"products":["v8n"],"published":"2022-08-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["imbrn"]},"summary":"An attacker can cause a denial of service in the v8n validation library by exploiting inefficient regular expressions in lowercase and uppercase checks.","url":"https://insights.sbomify.com/CVE-2022-35923/"}