# CVE-2022-35923: Inefficient Regular Expression Complexity in v8n

> An attacker can cause a denial of service in the v8n validation library by exploiting inefficient regular expressions in lowercase and uppercase checks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-xrx9-gj26-5wx9

## What is CVE-2022-35923?

CVE-2022-35923 is a high-severity denial of service vulnerability in imbrn v8n, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

v8n is a javascript validation library. Versions of v8n prior to 1.5.1 were found to have an inefficient regular expression complexity in the `lowercase()` and `uppercase()` regex which could lead to a denial of service attack. In testing of the `lowercase()` function a payload of 'a' + 'a'.repeat(i) + 'A' with 32 leading characters took 29443 ms to execute. The same issue happens with uppercase(). Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-35923?

2 open source packages ship an affected version, including v8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `v8n` | npm | All versions | 1.5.1 |
| `v8n` | npm | All versions | 1.5.1 |

Products: V8n Project V8n.

## How do I fix CVE-2022-35923?

Upgrade v8n to 1.5.1 or later.

## Is CVE-2022-35923 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35923 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35923 and fix it if it is affected.

What it is: CVE-2022-35923 is a high-severity denial of service vulnerability in imbrn v8n, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35923 exists.

Affected packages and fixed versions:
- v8n (npm): affected all versions; fixed in 1.5.1
- v8n (npm): affected all versions; fixed in 1.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35923/ (Markdown: https://insights.sbomify.com/CVE-2022-35923/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35923
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35923
- OSV: https://osv.dev/vulnerability/CVE-2022-35923

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35923/
Summaries are generated and may contain mistakes; the official description above is the record.
