CVE-2022-35924 Verification requests (magic link) sent to unwanted emails
Attackers can bypass email validation in NextAuth.js EmailProvider to log in as unauthorized users by sending comma-separated email lists.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-35924?
CVE-2022-35924 is a critical authentication bypass vulnerability in nextauthjs next-auth, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
NextAuth.js is a complete open source authentication solution for Next.js applications. `next-auth` users who are using the `EmailProvider` either in versions before `4.10.3` or `3.29.10` are affected. If an attacker could forge a request that sent a comma-separated list of emails (eg.: `[email protected],[email protected]`) to the sign-in endpoint, NextAuth.js would send emails to both the attacker and the victim's e-mail addresses. The attacker could then login as a newly created user with the email being `[email protected],[email protected]`. This means that basic authorization like `email.endsWith("@victim.com")` in the `signIn` callback would fail to communicate a threat to the developer and would let the attacker bypass authorization, even with an `@attacker.com` address. This vulnerability has been patched in `v4.10.3` and `v3.29.10` by normalizing the email value that is sent to the sign-in endpoint before accessing it anywhere else. We also added a `normalizeIdentifier` callback on the `EmailProvider` configuration, where you can further tweak your requirements for what your system considers a valid e-mail address. (E.g.: strict RFC2821 compliance). Users are advised to upgrade. There are no known workarounds for this vulnerability. If for some reason you cannot upgrade, you can normalize the incoming request using Advanced Initialization.
Which versions are affected by CVE-2022-35924?
4 open source packages ship an affected version, including next-auth. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
next-auth npm | All versions | 3.29.10 |
next-auth npm | All versions | 3.29.10 |
next-auth npm | From 4.0.0 | 4.10.3 |
next-auth npm | From 4.0.0 | 4.10.3 |
Products include Nextauth.js Next-Auth.
How do I fix CVE-2022-35924?
Upgrade next-auth to a fixed version for your release line: 3.29.10 or 4.10.3.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2022-35924 being exploited?
There is no known exploitation of CVE-2022-35924 in the wild and no public exploit code.
Other vulnerabilities in nextauthjs next-auth
- CVE-2023-27490 Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth
- CVE-2022-31093 Improper Handling of `callbackUrl` parameter in next-auth
- CVE-2022-31127 Improper handling of email input in next-auth
- CVE-2022-39263 NextAuth.js Upstash Adapter missing token verification
- CVE-2022-29214 URL Redirection to Untrusted Site ('Open Redirect') in next-auth
Sources
Also known as GHSA-xv97-c62v-4587.