{"answers":{"affected":"4 open source packages ship an affected version, including next-auth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-35924 in the wild and no public exploit code.","fix":"Upgrade next-auth to a fixed version for your release line: 3.29.10 or 4.10.3.","what":"CVE-2022-35924 is a critical authentication bypass vulnerability in nextauthjs next-auth, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-35924 and fix it if it is affected.\n\nWhat it is: CVE-2022-35924 is a critical authentication bypass vulnerability in nextauthjs next-auth, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-35924 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next-auth (npm): affected all versions; fixed in 3.29.10\n- next-auth (npm): affected all versions; fixed in 3.29.10\n- next-auth (npm): affected from 4.0.0; fixed in 4.10.3\n- next-auth (npm): affected from 4.0.0; fixed in 4.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35924/ (Markdown: https://insights.sbomify.com/CVE-2022-35924/index.md)","id":"CVE-2022-35924","markdown":"https://insights.sbomify.com/CVE-2022-35924/index.md","name":"CVE-2022-35924","record":{"aliases":["GHSA-xv97-c62v-4587"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"NextAuth.js authentication library","requires_auth":"none","summary":"Attackers can bypass email validation in NextAuth.js EmailProvider to log in as unauthorized users by sending comma-separated email lists.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"next-auth","vendor":"nextauth.js"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"NextAuth.js is a complete open source authentication solution for Next.js applications. `next-auth` users who are using the `EmailProvider` either in versions before `4.10.3` or `3.29.10` are affected. If an attacker could forge a request that sent a comma-separated list of emails (eg.: `attacker@attacker.com,victim@victim.com`) to the sign-in endpoint, NextAuth.js would send emails to both the attacker and the victim's e-mail addresses. The attacker could then login as a newly created user with the email being `attacker@attacker.com,victim@victim.com`. This means that basic authorization like `email.endsWith(\"@victim.com\")` in the `signIn` callback would fail to communicate a threat to the developer and would let the attacker bypass authorization, even with an `@attacker.com` address. This vulnerability has been patched in `v4.10.3` and `v3.29.10` by normalizing the email value that is sent to the sign-in endpoint before accessing it anywhere else. We also added a `normalizeIdentifier` callback on the `EmailProvider` configuration, where you can further tweak your requirements for what your system considers a valid e-mail address. (E.g.: strict RFC2821 compliance). Users are advised to upgrade. There are no known workarounds for this vulnerability. If for some reason you cannot upgrade, you can normalize the incoming request using Advanced Initialization.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Verification requests (magic link) sent to unwanted emails","id":"CVE-2022-35924","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":4,"n_references":8,"next":{"headline":"Missing rate limit in Authentication in bookwyrm","id":"CVE-2022-35925"},"packages":[{"ecosystem":"npm","fixed":["3.29.10"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-xv97-c62v-4587"},{"ecosystem":"npm","fixed":["3.29.10"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-xv97-c62v-4587"},{"ecosystem":"npm","fixed":["4.10.3"],"introduced":["4.0.0"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-xv97-c62v-4587"},{"ecosystem":"npm","fixed":["4.10.3"],"introduced":["4.0.0"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-xv97-c62v-4587"}],"prev":{"headline":"Inefficient Regular Expression Complexity in v8n","id":"CVE-2022-35923"},"products":["next-auth"],"published":"2022-08-02","related":[{"cvss_score":8.1,"headline":"Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth","id":"CVE-2023-27490","kev_date_added":null,"published":"2023-03-09"},{"cvss_score":7.5,"headline":"Improper Handling of `callbackUrl` parameter in next-auth","id":"CVE-2022-31093","kev_date_added":null,"published":"2022-06-27"},{"cvss_score":7.1,"headline":"Improper handling of email input in next-auth","id":"CVE-2022-31127","kev_date_added":null,"published":"2022-07-06"},{"cvss_score":6.8,"headline":"NextAuth.js Upstash Adapter missing token verification","id":"CVE-2022-39263","kev_date_added":null,"published":"2022-09-28"},{"cvss_score":6.1,"headline":"URL Redirection to Untrusted Site ('Open Redirect') in next-auth","id":"CVE-2022-29214","kev_date_added":null,"published":"2022-05-20"},{"cvss_score":6.1,"headline":"Default redirect callback vulnerable to open redirects","id":"CVE-2022-24858","kev_date_added":null,"published":"2022-04-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["nextauthjs"]},"summary":"Attackers can bypass email validation in NextAuth.js EmailProvider to log in as unauthorized users by sending comma-separated email lists.","url":"https://insights.sbomify.com/CVE-2022-35924/"}