# CVE-2022-35924: Verification requests (magic link) sent to unwanted emails

> Attackers can bypass email validation in NextAuth.js EmailProvider to log in as unauthorized users by sending comma-separated email lists.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-xv97-c62v-4587

## What is CVE-2022-35924?

CVE-2022-35924 is a critical authentication bypass vulnerability in nextauthjs next-auth, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NextAuth.js is a complete open source authentication solution for Next.js applications. `next-auth` users who are using the `EmailProvider` either in versions before `4.10.3` or `3.29.10` are affected. If an attacker could forge a request that sent a comma-separated list of emails (eg.: `attacker@attacker.com,victim@victim.com`) to the sign-in endpoint, NextAuth.js would send emails to both the attacker and the victim's e-mail addresses. The attacker could then login as a newly created user with the email being `attacker@attacker.com,victim@victim.com`. This means that basic authorization like `email.endsWith("@victim.com")` in the `signIn` callback would fail to communicate a threat to the developer and would let the attacker bypass authorization, even with an `@attacker.com` address. This vulnerability has been patched in `v4.10.3` and `v3.29.10` by normalizing the email value that is sent to the sign-in endpoint before accessing it anywhere else. We also added a `normalizeIdentifier` callback on the `EmailProvider` configuration, where you can further tweak your requirements for what your system considers a valid e-mail address. (E.g.: strict RFC2821 compliance). Users are advised to upgrade. There are no known workarounds for this vulnerability. If for some reason you cannot upgrade, you can normalize the incoming request using Advanced Initialization.

Weakness: CWE-863 (Incorrect Authorization), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-35924?

4 open source packages ship an affected version, including next-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next-auth` | npm | All versions | 3.29.10 |
| `next-auth` | npm | All versions | 3.29.10 |
| `next-auth` | npm | From 4.0.0 | 4.10.3 |
| `next-auth` | npm | From 4.0.0 | 4.10.3 |

Products: Nextauth.js Next-Auth.

## How do I fix CVE-2022-35924?

Upgrade next-auth to a fixed version for your release line: 3.29.10 or 4.10.3.

## Is CVE-2022-35924 being exploited?

There is no known exploitation of CVE-2022-35924 in the wild and no public exploit code.

## Other vulnerabilities in nextauthjs next-auth

- [CVE-2023-27490](https://insights.sbomify.com/CVE-2023-27490/): Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth (high 8.1)
- [CVE-2022-31093](https://insights.sbomify.com/CVE-2022-31093/): Improper Handling of `callbackUrl` parameter in next-auth (high 7.5)
- [CVE-2022-31127](https://insights.sbomify.com/CVE-2022-31127/): Improper handling of email input in next-auth (high 7.1)
- [CVE-2022-39263](https://insights.sbomify.com/CVE-2022-39263/): NextAuth.js Upstash Adapter missing token verification (medium 6.8)
- [CVE-2022-29214](https://insights.sbomify.com/CVE-2022-29214/): URL Redirection to Untrusted Site ('Open Redirect') in next-auth (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35924 and fix it if it is affected.

What it is: CVE-2022-35924 is a critical authentication bypass vulnerability in nextauthjs next-auth, published on 2 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35924 in the wild and no public exploit code.

Affected packages and fixed versions:
- next-auth (npm): affected all versions; fixed in 3.29.10
- next-auth (npm): affected all versions; fixed in 3.29.10
- next-auth (npm): affected from 4.0.0; fixed in 4.10.3
- next-auth (npm): affected from 4.0.0; fixed in 4.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35924/ (Markdown: https://insights.sbomify.com/CVE-2022-35924/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35924
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35924
- OSV: https://osv.dev/vulnerability/CVE-2022-35924

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35924/
Summaries are generated and may contain mistakes; the official description above is the record.
