{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-35927 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-35927 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-35927 is a high-severity memory corruption vulnerability in contiki-ng, published on 4 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-35927 and fix it if it is affected.\n\nWhat it is: CVE-2022-35927 is a high-severity memory corruption vulnerability in contiki-ng, published on 4 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-35927 in the wild and no public exploit code.\n\nAffected product: contiki-ng. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35927/ (Markdown: https://insights.sbomify.com/CVE-2022-35927/index.md)","id":"CVE-2022-35927","markdown":"https://insights.sbomify.com/CVE-2022-35927/index.md","name":"CVE-2022-35927","record":{"aliases":["GHSA-9rm9-3phh-p4wm"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"IoT operating system","requires_auth":"none","summary":"An attacker can trigger a buffer overflow in Contiki-NG's RPL-Classic implementation by sending malformed DIO messages, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"contiki-ng","vendor":"contiki-ng"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-120","name":"Buffer Copy without Checking Size of Input"}],"description":"Contiki-NG is an open-source, cross-platform operating system for IoT devices. In the RPL-Classic routing protocol implementation in the Contiki-NG operating system, an incoming DODAG Information Option (DIO) control message can contain a prefix information option with a length parameter. The value of the length parameter is not validated, however, and it is possible to cause a buffer overflow when copying the prefix in the set_ip_from_prefix function. This vulnerability affects anyone running a Contiki-NG version prior to 4.7 that can receive RPL DIO messages from external parties. To obtain a patched version, users should upgrade to Contiki-NG 4.7 or later. There are no workarounds for this issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Unverified DIO prefix info lengths in RPL-Classic in Contiki-NG","id":"CVE-2022-35927","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":0,"n_references":3,"next":{"headline":"AES Crypt for Linux Password Security Vulnerability","id":"CVE-2022-35928"},"packages":[],"prev":{"headline":"Out-of-bounds read in IPv6 neighbor solicitation in Contiki-NG","id":"CVE-2022-35926"},"products":["contiki-ng"],"published":"2022-08-04","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2018-19417","kev_date_added":null,"published":"2018-11-21"},{"cvss_score":9.8,"headline":"Contiki-NG has off-by-one error in Antelope DBMS","id":"CVE-2023-30546","kev_date_added":null,"published":"2023-04-26"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-24336","kev_date_added":null,"published":"2020-12-11"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-14934","kev_date_added":null,"published":"2020-08-18"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-14935","kev_date_added":null,"published":"2020-08-18"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2020-14936","kev_date_added":null,"published":"2020-08-18"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-8359","kev_date_added":null,"published":"2020-04-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["contiki-ng"]},"summary":"An attacker can trigger a buffer overflow in Contiki-NG's RPL-Classic implementation by sending malformed DIO messages, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2022-35927/"}