# CVE-2022-35927: Unverified DIO prefix info lengths in RPL-Classic in Contiki-NG

> An attacker can trigger a buffer overflow in Contiki-NG's RPL-Classic implementation by sending malformed DIO messages, potentially leading to code execution or crashes.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-9rm9-3phh-p4wm

## What is CVE-2022-35927?

CVE-2022-35927 is a high-severity memory corruption vulnerability in contiki-ng, published on 4 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Contiki-NG is an open-source, cross-platform operating system for IoT devices. In the RPL-Classic routing protocol implementation in the Contiki-NG operating system, an incoming DODAG Information Option (DIO) control message can contain a prefix information option with a length parameter. The value of the length parameter is not validated, however, and it is possible to cause a buffer overflow when copying the prefix in the set_ip_from_prefix function. This vulnerability affects anyone running a Contiki-NG version prior to 4.7 that can receive RPL DIO messages from external parties. To obtain a patched version, users should upgrade to Contiki-NG 4.7 or later. There are no workarounds for this issue.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2022-35927?

It affects 1 product.


Products: Contiki-Ng Contiki-Ng.

## How do I fix CVE-2022-35927?

No fix has been published for CVE-2022-35927 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-35927 being exploited?

There is no known exploitation of CVE-2022-35927 in the wild and no public exploit code.

## Other vulnerabilities in contiki-ng

- [CVE-2018-19417](https://insights.sbomify.com/CVE-2018-19417/): Memory corruption in n/a (critical 10.0)
- [CVE-2023-30546](https://insights.sbomify.com/CVE-2023-30546/): Contiki-NG has off-by-one error in Antelope DBMS (critical 9.8)
- [CVE-2020-24336](https://insights.sbomify.com/CVE-2020-24336/): Memory corruption in n/a (critical 9.8)
- [CVE-2020-14934](https://insights.sbomify.com/CVE-2020-14934/): Memory corruption in n/a (critical 9.8)
- [CVE-2020-14935](https://insights.sbomify.com/CVE-2020-14935/): Memory corruption in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35927 and fix it if it is affected.

What it is: CVE-2022-35927 is a high-severity memory corruption vulnerability in contiki-ng, published on 4 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35927 in the wild and no public exploit code.

Affected product: contiki-ng. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35927/ (Markdown: https://insights.sbomify.com/CVE-2022-35927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35927
- OSV: https://osv.dev/vulnerability/CVE-2022-35927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35927/
Summaries are generated and may contain mistakes; the official description above is the record.
