# CVE-2022-35929: False positive signature verification in cosign

> Attackers can bypass signature verification for specific attestation types, allowing unsigned or malicious container images to appear verified.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Aug 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-cosign-2022-35929, CLEANSTART-2026-EH64058, GHSA-vjxv-45g9-9296, GO-2022-0758, SUSE-SU-2022:2877-1, openSUSE-SU-2024:12240-1

## What is CVE-2022-35929?

CVE-2022-35929 is a high-severity vulnerability in sigstore cosign, published on 4 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

cosign is a container signing and verification utility. In versions prior to 1.10.1 cosign can report a false positive if any attestation exists. `cosign verify-attestation` used with the `--type` flag will report a false positive verification when there is at least one attestation with a valid signature and there are NO attestations of the type being verified (--type defaults to "custom"). This can happen when signing with a standard keypair and with "keyless" signing with Fulcio. This vulnerability can be reproduced with the `distroless.dev/static@sha256:dd7614b5a12bc4d617b223c588b4e0c833402b8f4991fb5702ea83afad1986e2` image. This image has a `vuln` attestation but not an `spdx` attestation. However, if you run `cosign verify-attestation --type=spdx` on this image, it incorrectly succeeds. This issue has been addressed in version 1.10.1 of cosign. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2022-35929?

4 open source packages ship an affected version, including github.com/sigstore/cosign and cosign. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/cosign` | Go | All versions | 1.10.1 |
| `github.com/sigstore/cosign` | Go | All versions | 1.10.1 |
| `github.com/sigstore/cosign` | Go | All versions | 1.10.1 |
| `cosign` | Bitnami | All versions | 1.10.1 |
| `cosign` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 1.10.1-150400.3.3.1 |
| `cosign` | openSUSE:Leap 15.4 | All versions | 1.10.1-150400.3.3.1 |
| `cosign` | openSUSE:Tumbleweed | All versions | 1.10.1-1.1 |

Products: Sigstore Cosign.

## How do I fix CVE-2022-35929?

Upgrade github.com/sigstore/cosign to 1.10.1 or later.

## Is CVE-2022-35929 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35929 exists.

## Other vulnerabilities in sigstore cosign

- [CVE-2026-22703](https://insights.sbomify.com/CVE-2026-22703/): Cosign verification accepts any valid Rekor entry under certain conditions (medium 5.5)
- [CVE-2022-36056](https://insights.sbomify.com/CVE-2022-36056/): Vulnerabilities with blob verification in sigstore cosign (medium 5.5)
- [CVE-2026-39395](https://insights.sbomify.com/CVE-2026-39395/): Cosign's verify-blob-attestation reports false positive when payload parsing fails (medium 4.3)
- [CVE-2024-29902](https://insights.sbomify.com/CVE-2024-29902/): Cosign vulnerable to system-wide denial of service via malicious attachments (medium 4.2)
- [CVE-2024-29903](https://insights.sbomify.com/CVE-2024-29903/): Cosign vulnerable to machine-wide denial of service via malicious artifacts (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35929 and fix it if it is affected.

What it is: CVE-2022-35929 is a high-severity vulnerability in sigstore cosign, published on 4 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35929 exists.

Affected packages and fixed versions:
- github.com/sigstore/cosign (Go): affected all versions; fixed in 1.10.1
- github.com/sigstore/cosign (Go): affected all versions; fixed in 1.10.1
- github.com/sigstore/cosign (Go): affected all versions; fixed in 1.10.1
- cosign (Bitnami): affected all versions; fixed in 1.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35929/ (Markdown: https://insights.sbomify.com/CVE-2022-35929/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35929
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35929
- OSV: https://osv.dev/vulnerability/CVE-2022-35929

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35929/
Summaries are generated and may contain mistakes; the official description above is the record.
