{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/productcomments. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-35933 in the wild and no public exploit code.","fix":"Upgrade prestashop/productcomments to 5.0.2 or later.","what":"CVE-2022-35933 is a medium-severity cross-site scripting vulnerability in PrestaShop productcomments, published on 2 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-35933 and fix it if it is affected.\n\nWhat it is: CVE-2022-35933 is a medium-severity cross-site scripting vulnerability in PrestaShop productcomments, published on 2 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-35933 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/productcomments (Packagist): affected all versions; fixed in 5.0.2\n- prestashop/productcomments (Packagist): affected all versions; fixed in 5.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35933/ (Markdown: https://insights.sbomify.com/CVE-2022-35933/index.md)","id":"CVE-2022-35933","markdown":"https://insights.sbomify.com/CVE-2022-35933/index.md","name":"CVE-2022-35933","record":{"aliases":["GHSA-prrh-qvhf-x788"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop module","requires_auth":"none","summary":"An attacker can steal administrator cookies via cross-site scripting in the Product Comments module, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"productcomments","vendor":"prestashop"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"This package is a PrestaShop module that allows users to post reviews and rate products. There is a vulnerability where the attacker could steal an administrator's cookie. The issue is fixed in version 5.0.2.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PrestaShop module Product Comments vulnerable to cross-site scripting (XSS)","id":"CVE-2022-35933","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"`CHECK` failure in tf.reshape in Tensorflow","id":"CVE-2022-35934"},"packages":[{"ecosystem":"Packagist","fixed":["5.0.2"],"introduced":["0"],"last_affected":[],"package":"prestashop/productcomments","purl":null,"source":"GHSA-prrh-qvhf-x788"},{"ecosystem":"Packagist","fixed":["5.0.2"],"introduced":["0"],"last_affected":[],"package":"prestashop/productcomments","purl":"pkg:composer/prestashop/productcomments","source":"GHSA-prrh-qvhf-x788"}],"prev":{"headline":"Missing rate limit when trying to join a password protected Nextcloud Talk conversation","id":"CVE-2022-35932"},"products":["productcomments"],"published":"2022-09-02","related":[{"cvss_score":6.8,"headline":"Blind SQL injection during the CommentGrade process","id":"CVE-2020-26248","kev_date_added":null,"published":"2020-12-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["PrestaShop"]},"summary":"An attacker can steal administrator cookies via cross-site scripting in the Product Comments module, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2022-35933/"}