# CVE-2022-35933: PrestaShop module Product Comments vulnerable to cross-site scripting (XSS)

> An attacker can steal administrator cookies via cross-site scripting in the Product Comments module, potentially leading to account takeover.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-prrh-qvhf-x788

## What is CVE-2022-35933?

CVE-2022-35933 is a medium-severity cross-site scripting vulnerability in PrestaShop productcomments, published on 2 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

This package is a PrestaShop module that allows users to post reviews and rate products. There is a vulnerability where the attacker could steal an administrator's cookie. The issue is fixed in version 5.0.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-35933?

2 open source packages ship an affected version, including prestashop/productcomments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/productcomments` | Packagist | All versions | 5.0.2 |
| `prestashop/productcomments` | Packagist | All versions | 5.0.2 |

Products: Prestashop Productcomments.

## How do I fix CVE-2022-35933?

Upgrade prestashop/productcomments to 5.0.2 or later.

## Is CVE-2022-35933 being exploited?

There is no known exploitation of CVE-2022-35933 in the wild and no public exploit code.

## Other vulnerabilities in PrestaShop productcomments

- [CVE-2020-26248](https://insights.sbomify.com/CVE-2020-26248/): Blind SQL injection during the CommentGrade process (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35933 and fix it if it is affected.

What it is: CVE-2022-35933 is a medium-severity cross-site scripting vulnerability in PrestaShop productcomments, published on 2 Sep 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-35933 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/productcomments (Packagist): affected all versions; fixed in 5.0.2
- prestashop/productcomments (Packagist): affected all versions; fixed in 5.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35933/ (Markdown: https://insights.sbomify.com/CVE-2022-35933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35933
- OSV: https://osv.dev/vulnerability/CVE-2022-35933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35933/
Summaries are generated and may contain mistakes; the official description above is the record.
