{"answers":{"affected":"3 open source packages ship an affected version, including codeigniter4/shield and codeigniter. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35943 exists.","fix":"Upgrade codeigniter4/shield to 1.0.0-beta.2 or later.","what":"CVE-2022-35943 is a medium-severity vulnerability in codeigniter4 shield, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-35943 and fix it if it is affected.\n\nWhat it is: CVE-2022-35943 is a medium-severity vulnerability in codeigniter4 shield, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35943 exists.\n\nAffected packages and fixed versions:\n- codeigniter4/shield (Packagist): affected from 1.0.0-beta; fixed in 1.0.0-beta.2\n- codeigniter4/shield (Packagist): affected from 1.0.0-beta; fixed in 1.0.0-beta.2\n- codeigniter (Bitnami): affected all versions; fixed in 4.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35943/ (Markdown: https://insights.sbomify.com/CVE-2022-35943/index.md)","id":"CVE-2022-35943","markdown":"https://insights.sbomify.com/CVE-2022-35943/index.md","name":"CVE-2022-35943","record":{"aliases":["BIT-codeigniter-2022-35943","GHSA-5hm8-vh6r-2cjq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"CodeIgniter Shield","requires_auth":"none","summary":"Attackers with subdomain control can bypass CSRF protection in CodeIgniter Shield, potentially allowing unauthorized actions on behalf of authenticated users.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"codeigniter","vendor":"codeigniter"},{"product":"shield","vendor":"codeigniter"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Shield is an authentication and authorization framework for CodeIgniter 4. This vulnerability may allow [SameSite Attackers](https://canitakeyoursubdomain.name/) to bypass the [CodeIgniter4 CSRF protection](https://codeigniter4.github.io/userguide/libraries/security.html) mechanism with CodeIgniter Shield. For this attack to succeed, the attacker must have direct (or indirect, e.g., XSS) control over a subdomain site (e.g., `https://a.example.com/`) of the target site (e.g., `http://example.com/`). Upgrade to **CodeIgniter v4.2.3 or later** and **Shield v1.0.0-beta.2 or later**. As a workaround: set `Config\\Security::$csrfProtection` to `'session,'`remove old session data right after login (immediately after ID and password match) and regenerate CSRF token right after login (immediately after ID and password match)","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"SameSite may allow cross-site request forgery (CSRF) protection to be bypassed","id":"CVE-2022-35943","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"csrf","year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"October CMS Safe Mode bypass leads to authenticated RCE (Remote Code Execution)","id":"CVE-2022-35944"},"packages":[{"ecosystem":"Bitnami","fixed":["4.2.3"],"introduced":["0"],"last_affected":[],"package":"codeigniter","purl":"pkg:bitnami/codeigniter","source":"BIT-codeigniter-2022-35943"},{"ecosystem":"Packagist","fixed":["1.0.0-beta.2"],"introduced":["1.0.0-beta"],"last_affected":[],"package":"codeigniter4/shield","purl":null,"source":"GHSA-5hm8-vh6r-2cjq"},{"ecosystem":"Packagist","fixed":["1.0.0-beta.2"],"introduced":["1.0.0-beta"],"last_affected":[],"package":"codeigniter4/shield","purl":"pkg:composer/codeigniter4/shield","source":"GHSA-5hm8-vh6r-2cjq"}],"prev":{"headline":"loopback-connector-postgresql Vulnerable to Improper Sanitization of `contains` Filter","id":"CVE-2022-35942"},"products":["shield"],"published":"2022-08-12","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["codeigniter4"]},"summary":"Attackers with subdomain control can bypass CSRF protection in CodeIgniter Shield, potentially allowing unauthorized actions on behalf of authenticated users.","url":"https://insights.sbomify.com/CVE-2022-35943/"}