# CVE-2022-35943: SameSite may allow cross-site request forgery (CSRF) protection to be bypassed

> Attackers with subdomain control can bypass CSRF protection in CodeIgniter Shield, potentially allowing unauthorized actions on behalf of authenticated users.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Aug 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-codeigniter-2022-35943, GHSA-5hm8-vh6r-2cjq

## What is CVE-2022-35943?

CVE-2022-35943 is a medium-severity vulnerability in codeigniter4 shield, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Shield is an authentication and authorization framework for CodeIgniter 4. This vulnerability may allow [SameSite Attackers](https://canitakeyoursubdomain.name/) to bypass the [CodeIgniter4 CSRF protection](https://codeigniter4.github.io/userguide/libraries/security.html) mechanism with CodeIgniter Shield. For this attack to succeed, the attacker must have direct (or indirect, e.g., XSS) control over a subdomain site (e.g., `https://a.example.com/`) of the target site (e.g., `http://example.com/`). Upgrade to **CodeIgniter v4.2.3 or later** and **Shield v1.0.0-beta.2 or later**. As a workaround: set `Config\Security::$csrfProtection` to `'session,'`remove old session data right after login (immediately after ID and password match) and regenerate CSRF token right after login (immediately after ID and password match)

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-35943?

3 open source packages ship an affected version, including codeigniter4/shield and codeigniter. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/shield` | Packagist | From 1.0.0-beta | 1.0.0-beta.2 |
| `codeigniter4/shield` | Packagist | From 1.0.0-beta | 1.0.0-beta.2 |
| `codeigniter` | Bitnami | All versions | 4.2.3 |

Products: Codeigniter Codeigniter, Codeigniter Shield.

## How do I fix CVE-2022-35943?

Upgrade codeigniter4/shield to 1.0.0-beta.2 or later.

## Is CVE-2022-35943 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35943 exists.

## Other vulnerabilities in codeigniter4 shield

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35943 and fix it if it is affected.

What it is: CVE-2022-35943 is a medium-severity vulnerability in codeigniter4 shield, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35943 exists.

Affected packages and fixed versions:
- codeigniter4/shield (Packagist): affected from 1.0.0-beta; fixed in 1.0.0-beta.2
- codeigniter4/shield (Packagist): affected from 1.0.0-beta; fixed in 1.0.0-beta.2
- codeigniter (Bitnami): affected all versions; fixed in 4.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35943/ (Markdown: https://insights.sbomify.com/CVE-2022-35943/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35943
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35943
- OSV: https://osv.dev/vulnerability/CVE-2022-35943

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35943/
Summaries are generated and may contain mistakes; the official description above is the record.
