# CVE-2022-35949: `undici.request` vulnerable to SSRF using absolute URL on `pathname`

> Attackers can exploit SSRF in undici library by manipulating pathname input to redirect requests to internal services, affecting Node.js applications using this HTTP client.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2022
- **Updated:** 22 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-35949, GHSA-8qr4-xgw6-wmr3

## What is CVE-2022-35949?

CVE-2022-35949 is a medium-severity server-side request forgery vulnerability in Nodejs Undici, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici is an HTTP/1.1 client, written from scratch for Node.js.`undici` is vulnerable to SSRF (Server-side Request Forgery) when an application takes in **user input** into the `path/pathname` option of `undici.request`. If a user specifies a URL such as `http://127.0.0.1` or `//127.0.0.1` ```js const undici = require("undici") undici.request({origin: "http://example.com", pathname: "//127.0.0.1"}) ``` Instead of processing the request as `http://example.org//127.0.0.1` (or `http://example.org/http://127.0.0.1` when `http://127.0.0.1 is used`), it actually processes the request as `http://127.0.0.1/` and sends it to `http://127.0.0.1`. If a developer passes in user input into `path` parameter of `undici.request`, it can result in an _SSRF_ as they will assume that the hostname cannot change, when in actual fact it can change because the specified path parameter is combined with the base URL. This issue was fixed in `undici@5.8.1`. The best workaround is to validate user input before passing it to the `undici.request` call.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-35949?

2 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | All versions | 5.8.2 |
| `undici` | npm | All versions | 5.8.2 |

Products: Nodejs Undici.

## How do I fix CVE-2022-35949?

Upgrade undici to 5.8.2 or later.

## Is CVE-2022-35949 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35949 exists.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35949 and fix it if it is affected.

What it is: CVE-2022-35949 is a medium-severity server-side request forgery vulnerability in Nodejs Undici, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-35949 exists.

Affected packages and fixed versions:
- undici (npm): affected all versions; fixed in 5.8.2
- undici (npm): affected all versions; fixed in 5.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35949/ (Markdown: https://insights.sbomify.com/CVE-2022-35949/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35949
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35949
- OSV: https://osv.dev/vulnerability/CVE-2022-35949

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35949/
Summaries are generated and may contain mistakes; the official description above is the record.
