{"answers":{"affected":"2 open source packages ship an affected version, including @actions/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-35954 in the wild and no public exploit code.","fix":"Upgrade @actions/core to 1.9.1 or later.","what":"CVE-2022-35954 is a medium-severity code injection vulnerability in actions toolkit, published on 13 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-35954 and fix it if it is affected.\n\nWhat it is: CVE-2022-35954 is a medium-severity code injection vulnerability in actions toolkit, published on 13 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-35954 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @actions/core (npm): affected all versions; fixed in 1.9.1\n- @actions/core (npm): affected all versions; fixed in 1.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35954/ (Markdown: https://insights.sbomify.com/CVE-2022-35954/index.md)","id":"CVE-2022-35954","markdown":"https://insights.sbomify.com/CVE-2022-35954/index.md","name":"CVE-2022-35954","record":{"aliases":["GHSA-7r3h-m5j6-3q42"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GitHub Actions Toolkit","requires_auth":"low_privilege","summary":"Attackers can inject delimiters to modify environment variables, potentially leading to privilege escalation or code execution in GitHub Actions workflows.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"toolkit","vendor":"github"}],"cvss":{"score":5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"The GitHub Actions ToolKit provides a set of packages to make creating actions easier. The `core.exportVariable` function uses a well known delimiter that attackers can use to break out of that specific variable and assign values to other arbitrary variables. Workflows that write untrusted values to the `GITHUB_ENV` file may cause the path or other environment variables to be modified without the intention of the workflow or action author. Users should upgrade to `@actions/core v1.9.1`. If you are unable to upgrade the `@actions/core` package, you can modify your action to ensure that any user input does not contain the delimiter `_GitHubActionsFileCommandDelimeter_` before calling `core.exportVariable`.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Delimiter injection vulnerability in @actions/core exportVariable","id":"CVE-2022-35954","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"update_by_case before 0.1.3 vulnerable to sql injection","id":"CVE-2022-35956"},"packages":[{"ecosystem":"npm","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"@actions/core","purl":null,"source":"GHSA-7r3h-m5j6-3q42"},{"ecosystem":"npm","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"@actions/core","purl":"pkg:npm/%40actions/core","source":"GHSA-7r3h-m5j6-3q42"}],"prev":{"headline":"URL Redirection to Untrusted Site ('Open Redirect') in bookwyrm","id":"CVE-2022-35953"},"products":["toolkit"],"published":"2022-08-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["actions"]},"summary":"Attackers can inject delimiters to modify environment variables, potentially leading to privilege escalation or code execution in GitHub Actions workflows.","url":"https://insights.sbomify.com/CVE-2022-35954/"}