# CVE-2022-35954: Delimiter injection vulnerability in @actions/core exportVariable

> Attackers can inject delimiters to modify environment variables, potentially leading to privilege escalation or code execution in GitHub Actions workflows.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-7r3h-m5j6-3q42

## What is CVE-2022-35954?

CVE-2022-35954 is a medium-severity code injection vulnerability in actions toolkit, published on 13 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The GitHub Actions ToolKit provides a set of packages to make creating actions easier. The `core.exportVariable` function uses a well known delimiter that attackers can use to break out of that specific variable and assign values to other arbitrary variables. Workflows that write untrusted values to the `GITHUB_ENV` file may cause the path or other environment variables to be modified without the intention of the workflow or action author. Users should upgrade to `@actions/core v1.9.1`. If you are unable to upgrade the `@actions/core` package, you can modify your action to ensure that any user input does not contain the delimiter `_GitHubActionsFileCommandDelimeter_` before calling `core.exportVariable`.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2022-35954?

2 open source packages ship an affected version, including @actions/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@actions/core` | npm | All versions | 1.9.1 |
| `@actions/core` | npm | All versions | 1.9.1 |

Products: Github Toolkit.

## How do I fix CVE-2022-35954?

Upgrade @actions/core to 1.9.1 or later.

## Is CVE-2022-35954 being exploited?

There is no known exploitation of CVE-2022-35954 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35954 and fix it if it is affected.

What it is: CVE-2022-35954 is a medium-severity code injection vulnerability in actions toolkit, published on 13 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35954 in the wild and no public exploit code.

Affected packages and fixed versions:
- @actions/core (npm): affected all versions; fixed in 1.9.1
- @actions/core (npm): affected all versions; fixed in 1.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35954/ (Markdown: https://insights.sbomify.com/CVE-2022-35954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35954
- OSV: https://osv.dev/vulnerability/CVE-2022-35954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35954/
Summaries are generated and may contain mistakes; the official description above is the record.
