# CVE-2022-35956: update_by_case before 0.1.3 vulnerable to sql injection

> Attackers can execute arbitrary SQL commands via unsanitized inputs in the update_by_case gem, potentially reading or modifying database records.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-33wh-w4m7-c6r8

## What is CVE-2022-35956?

CVE-2022-35956 is a medium-severity SQL injection vulnerability in camilova activerecord-update-by-case, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

This Rails gem adds two methods to the ActiveRecord::Base class that allow you to update many records on a single database hit, using a case sql statement for it. Before version 0.1.3 `update_by_case` gem used custom sql strings, and it was not sanitized, making it vulnerable to sql injection. Upgrade to version >= 0.1.3 that uses `Arel` instead to construct the resulting sql statement, with sanitized sql.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-35956?

2 open source packages ship an affected version, including update_by_case. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `update_by_case` | RubyGems | All versions | 0.1.3 |
| `update_by_case` | RubyGems | All versions | 0.1.3 |

Products: Update by Case Project Update by Case.

## How do I fix CVE-2022-35956?

Upgrade update_by_case to 0.1.3 or later.

## Is CVE-2022-35956 being exploited?

There is no known exploitation of CVE-2022-35956 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35956 and fix it if it is affected.

What it is: CVE-2022-35956 is a medium-severity SQL injection vulnerability in camilova activerecord-update-by-case, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-35956 in the wild and no public exploit code.

Affected packages and fixed versions:
- update_by_case (RubyGems): affected all versions; fixed in 0.1.3
- update_by_case (RubyGems): affected all versions; fixed in 0.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35956/ (Markdown: https://insights.sbomify.com/CVE-2022-35956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35956
- OSV: https://osv.dev/vulnerability/CVE-2022-35956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35956/
Summaries are generated and may contain mistakes; the official description above is the record.
