# CVE-2022-35961: ECDSA signature malleability in OpenZeppelin Contracts

> Attackers can bypass signature reuse protections in smart contracts by submitting malleable ECDSA signatures in alternative formats.

- **Severity:** High 7.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4h98-2769-gh6h

## What is CVE-2022-35961?

CVE-2022-35961 is a high-severity vulnerability in openzeppelin-contracts, published on 14 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

OpenZeppelin Contracts is a library for secure smart contract development. The functions `ECDSA.recover` and `ECDSA.tryRecover` are vulnerable to a kind of signature malleability due to accepting EIP-2098 compact signatures in addition to the traditional 65 byte signature format. This is only an issue for the functions that take a single `bytes` argument, and not the functions that take `r, v, s` or `r, vs` as separate arguments. The potentially affected contracts are those that implement signature reuse or replay protection by marking the signature itself as used rather than the signed message or a nonce included in it. A user may take a signature that has already been submitted, submit it again in a different form, and bypass this protection. The issue has been patched in 4.7.3.

Weakness: CWE-354 (Improper Validation of Integrity Check Value)

## Which versions are affected by CVE-2022-35961?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.1.0 | 4.7.3 |
| `@openzeppelin/contracts` | npm | From 4.1.0 | 4.7.3 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.1.0 | 4.7.3 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.1.0 | 4.7.3 |

Products: Openzeppelin Contracts, Openzeppelin Contracts Upgradeable.

## How do I fix CVE-2022-35961?

Upgrade @openzeppelin/contracts to 4.7.3 or later.

## Is CVE-2022-35961 being exploited?

There is no known exploitation of CVE-2022-35961 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)
- [CVE-2022-31170](https://insights.sbomify.com/CVE-2022-31170/): OpenZeppelin Contracts's ERC165Checker may revert instead of returning false (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35961 and fix it if it is affected.

What it is: CVE-2022-35961 is a high-severity vulnerability in openzeppelin-contracts, published on 14 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-35961 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.1.0; fixed in 4.7.3
- @openzeppelin/contracts (npm): affected from 4.1.0; fixed in 4.7.3
- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.7.3
- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.7.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35961/ (Markdown: https://insights.sbomify.com/CVE-2022-35961/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35961
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35961
- OSV: https://osv.dev/vulnerability/CVE-2022-35961

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35961/
Summaries are generated and may contain mistakes; the official description above is the record.
