{"answers":{"affected":"2 open source packages ship an affected version, including org.opensearch.plugin:opensearch-security. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-35980 in the wild and no public exploit code.","fix":"Upgrade org.opensearch.plugin:opensearch-security to 2.2.0.0 or later.","what":"CVE-2022-35980 is a high-severity missing authorization vulnerability in opensearch-project security, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-35980 and fix it if it is affected.\n\nWhat it is: CVE-2022-35980 is a high-severity missing authorization vulnerability in opensearch-project security, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-35980 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opensearch.plugin:opensearch-security (Maven): affected from 2.0.0.0; fixed in 2.2.0.0\n- org.opensearch.plugin:opensearch-security (Maven): affected from 2.0.0.0; fixed in 2.2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-35980/ (Markdown: https://insights.sbomify.com/CVE-2022-35980/index.md)","id":"CVE-2022-35980","markdown":"https://insights.sbomify.com/CVE-2022-35980/index.md","name":"CVE-2022-35980","record":{"aliases":["GHSA-f4qr-f4xx-hjxw"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"OpenSearch security plugin","requires_auth":"none","summary":"Attackers can bypass document and field level security filters on aliased indices, exposing sensitive information in OpenSearch clusters.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opensearch","vendor":"amazon"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-612","name":"Improper Authorization of Index Containing Sensitive Information"}],"description":"OpenSearch Security is a plugin for OpenSearch that offers encryption, authentication and authorization. Versions 2.0.0.0 and 2.1.0.0 of the security plugin are affected by an information disclosure vulnerability. Requests to an OpenSearch cluster configured with advanced access control features document level security (DLS), field level security (FLS), and/or field masking will not be filtered when the query's search pattern matches an aliased index. OpenSearch Dashboards creates an alias to `.kibana` by default, so filters with the index pattern of `*` to restrict access to documents or fields will not be applied. This issue allows requests to access sensitive information when customer have acted to restrict access that specific information. OpenSearch 2.2.0, which is compatible with OpenSearch Security 2.2.0.0, contains the fix for this issue. There is no recommended work around.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information","id":"CVE-2022-35980","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"`CHECK` fail in `FractionalMaxPoolGrad` in TensorFlow","id":"CVE-2022-35981"},"packages":[{"ecosystem":"Maven","fixed":["2.2.0.0"],"introduced":["2.0.0.0"],"last_affected":[],"package":"org.opensearch.plugin:opensearch-security","purl":null,"source":"GHSA-f4qr-f4xx-hjxw"},{"ecosystem":"Maven","fixed":["2.2.0.0"],"introduced":["2.0.0.0"],"last_affected":[],"package":"org.opensearch.plugin:opensearch-security","purl":"pkg:maven/org.opensearch.plugin/opensearch-security","source":"GHSA-f4qr-f4xx-hjxw"}],"prev":{"headline":"Segfault in `QuantizedRelu` and `QuantizedRelu6`","id":"CVE-2022-35979"},"products":["security"],"published":"2022-08-12","related":[{"cvss_score":8.8,"headline":"Unsafe YAML deserialization in opensearch-ruby","id":"CVE-2022-31115","kev_date_added":null,"published":"2022-06-30"},{"cvss_score":8.3,"headline":"OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS","id":"CVE-2025-9624","kev_date_added":null,"published":"2025-11-25"},{"cvss_score":6.3,"headline":"Issue with fine-grained access control of indices backing data streams","id":"CVE-2022-41918","kev_date_added":null,"published":"2022-11-15"},{"cvss_score":5.7,"headline":"Issue in Anomaly Detection with document and field level rules in numerical feature aggregations","id":"CVE-2023-23933","kev_date_added":null,"published":"2023-02-03"},{"cvss_score":5.7,"headline":"Field-level security issue with .keyword fields in OpenSearch","id":"CVE-2023-23613","kev_date_added":null,"published":"2023-01-24"},{"cvss_score":5.4,"headline":"OpenSearch Issue with tenant read-only permissions","id":"CVE-2023-45807","kev_date_added":null,"published":"2023-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["opensearch-project"]},"summary":"Attackers can bypass document and field level security filters on aliased indices, exposing sensitive information in OpenSearch clusters.","url":"https://insights.sbomify.com/CVE-2022-35980/"}