# CVE-2022-35980: OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information

> Attackers can bypass document and field level security filters on aliased indices, exposing sensitive information in OpenSearch clusters.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-f4qr-f4xx-hjxw

## What is CVE-2022-35980?

CVE-2022-35980 is a high-severity missing authorization vulnerability in opensearch-project security, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSearch Security is a plugin for OpenSearch that offers encryption, authentication and authorization. Versions 2.0.0.0 and 2.1.0.0 of the security plugin are affected by an information disclosure vulnerability. Requests to an OpenSearch cluster configured with advanced access control features document level security (DLS), field level security (FLS), and/or field masking will not be filtered when the query's search pattern matches an aliased index. OpenSearch Dashboards creates an alias to `.kibana` by default, so filters with the index pattern of `*` to restrict access to documents or fields will not be applied. This issue allows requests to access sensitive information when customer have acted to restrict access that specific information. OpenSearch 2.2.0, which is compatible with OpenSearch Security 2.2.0.0, contains the fix for this issue. There is no recommended work around.

Weakness: CWE-612 (Improper Authorization of Index Containing Sensitive Information)

## Which versions are affected by CVE-2022-35980?

2 open source packages ship an affected version, including org.opensearch.plugin:opensearch-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opensearch.plugin:opensearch-security` | Maven | From 2.0.0.0 | 2.2.0.0 |
| `org.opensearch.plugin:opensearch-security` | Maven | From 2.0.0.0 | 2.2.0.0 |

Products: Amazon Opensearch.

## How do I fix CVE-2022-35980?

Upgrade org.opensearch.plugin:opensearch-security to 2.2.0.0 or later.

## Is CVE-2022-35980 being exploited?

There is no known exploitation of CVE-2022-35980 in the wild and no public exploit code.

## Other vulnerabilities in opensearch-project security

- [CVE-2022-31115](https://insights.sbomify.com/CVE-2022-31115/): Unsafe YAML deserialization in opensearch-ruby (high 8.8)
- [CVE-2025-9624](https://insights.sbomify.com/CVE-2025-9624/): OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS (high 8.3)
- [CVE-2022-41918](https://insights.sbomify.com/CVE-2022-41918/): Issue with fine-grained access control of indices backing data streams (medium 6.3)
- [CVE-2023-23933](https://insights.sbomify.com/CVE-2023-23933/): Issue in Anomaly Detection with document and field level rules in numerical feature aggregations (medium 5.7)
- [CVE-2023-23613](https://insights.sbomify.com/CVE-2023-23613/): Field-level security issue with .keyword fields in OpenSearch (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-35980 and fix it if it is affected.

What it is: CVE-2022-35980 is a high-severity missing authorization vulnerability in opensearch-project security, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-35980 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opensearch.plugin:opensearch-security (Maven): affected from 2.0.0.0; fixed in 2.2.0.0
- org.opensearch.plugin:opensearch-security (Maven): affected from 2.0.0.0; fixed in 2.2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-35980/ (Markdown: https://insights.sbomify.com/CVE-2022-35980/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-35980
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-35980
- OSV: https://osv.dev/vulnerability/CVE-2022-35980

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-35980/
Summaries are generated and may contain mistakes; the official description above is the record.
