# CVE-2022-36007: Partial Path Traversal in com.github.jlangch:venice

> Attackers can read files outside configured load paths if absolute paths share a prefix with allowed directories, affecting Venice library users.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Aug 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-4mmh-5vw7-rgvj

## What is CVE-2022-36007?

CVE-2022-36007 is a medium-severity path traversal vulnerability in jlangch venice, published on 14 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Venice is a Clojure inspired sandboxed Lisp dialect with excellent Java interoperability. A partial path traversal issue exists within the functions `load-file` and `load-resource`. These functions can be limited to load files from a list of load paths. Assuming Venice has been configured with the load paths: `[ "/Users/foo/resources" ]` When passing **relative** paths to these two vulnerable functions everything is fine: `(load-resource "test.png")` => loads the file "/Users/foo/resources/test.png" `(load-resource "../resources-alt/test.png")` => rejected, outside the load path When passing **absolute** paths to these two vulnerable functions Venice may return files outside the configured load paths: `(load-resource "/Users/foo/resources/test.png")` => loads the file "/Users/foo/resources/test.png" `(load-resource "/Users/foo/resources-alt/test.png")` => loads the file "/Users/foo/resources-alt/test.png" !!! The latter call suffers from the _Partial Path Traversal_ vulnerability. This issue’s scope is limited to absolute paths whose name prefix matches a load path. E.g. for a load-path `"/Users/foo/resources"`, the actor can cause loading a resource also from `"/Users/foo/resources-alt"`, but not from `"/Users/foo/images"`. Versions of Venice before and including v1.10.17 are affected by this issue. Upgrade to Venice >= 1.10.18, if you are on a version < 1.10.18. There are currently no known workarounds.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-36007?

2 open source packages ship an affected version, including com.github.jlangch:venice. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.github.jlangch:venice` | Maven | All versions | 1.10.17 |
| `com.github.jlangch:venice` | Maven | All versions | 1.10.17 |

Products: Venice Project Venice.

## How do I fix CVE-2022-36007?

Upgrade com.github.jlangch:venice to 1.10.17 or later.

## Is CVE-2022-36007 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36007 exists.

Public exploit code:

- https://github.com/shoucheng3/jlangch__venice_CVE-2022-36007_1-10-16 (github_poc): https://github.com/shoucheng3/jlangch__venice_CVE-2022-36007_1-10-16

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36007 and fix it if it is affected.

What it is: CVE-2022-36007 is a medium-severity path traversal vulnerability in jlangch venice, published on 14 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36007 exists.

Affected packages and fixed versions:
- com.github.jlangch:venice (Maven): affected all versions; fixed in 1.10.17
- com.github.jlangch:venice (Maven): affected all versions; fixed in 1.10.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36007/ (Markdown: https://insights.sbomify.com/CVE-2022-36007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36007
- OSV: https://osv.dev/vulnerability/CVE-2022-36007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36007/
Summaries are generated and may contain mistakes; the official description above is the record.
