# CVE-2022-3602: X.509 Email Address 4-byte Buffer Overflow

> A buffer overflow in OpenSSL X.509 verification allows attackers to cause crashes or potentially execute code via malicious certificates.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Nov 2022
- **Updated:** 14 Apr 2026
- **Also known as:** ALPINE-CVE-2022-3602, BIT-node-2022-3602, BIT-node-min-2022-3602, CLEANSTART-2026-HF71338, CLEANSTART-2026-ZX41424, DEBIAN-CVE-2022-3602, GHSA-8rwr-x37p-mx23, RUSTSEC-2022-0064, UBUNTU-CVE-2022-3602, openSUSE-SU-2024:12575-1

## What is CVE-2022-3602?

CVE-2022-3602 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed the malicious certificate or for the application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address to overflow four attacker-controlled bytes on the stack. This buffer overflow could result in a crash (causing a denial of service) or potentially remote code execution. Many platforms implement stack overflow protections which would mitigate against the risk of remote code execution. The risk may be further mitigated based on stack layout for any given platform/compiler. Pre-announcements of CVE-2022-3602 described this issue as CRITICAL. Further analysis based on some of the mitigating factors described above have led this to be downgraded to HIGH. Users are still encouraged to upgrade to a new version as soon as possible. In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects. Fixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6).

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2022-3602?

5 open source packages ship an affected version, including openssl-src, node and node-min. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.11 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.11 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.11 |
| `node` | Bitnami | From 18.0.0 | 18.11.0, 18.12.1, 19.0.1 |
| `node-min` | Bitnami | From 18.0.0 | 18.11.0, 18.12.1, 19.0.1 |

Products: Fedoraproject Fedora, Netapp Clustered Data Ontap, Nodejs Node.js, Openssl Openssl.

## How do I fix CVE-2022-3602?

Upgrade openssl-src to 300.0.11 or later.

## Is CVE-2022-3602 being exploited?

There is no known exploitation of CVE-2022-3602 in the wild and no public exploit code.

Public exploit code:

- Operational information regarding CVE-2022-3602 and CVE-2022-3786, two vulnerabilities in OpenSSL 3 (github_poc): https://github.com/NCSC-NL/OpenSSL-2022
- https://github.com/colmmacc/CVE-2022-3602 (github_poc): https://github.com/colmmacc/CVE-2022-3602
- https://github.com/rbowes-r7/cve-2022-3602-and-cve-2022-3786-openssl-poc (github_poc): https://github.com/rbowes-r7/cve-2022-3602-and-cve-2022-3786-openssl-poc
- https://github.com/eatscrayon/CVE-2022-3602-poc (github_poc): https://github.com/eatscrayon/CVE-2022-3602-poc
- Detects attempts at exploitation of CVE-2022-3602, a remote code execution vulnerability in OpenSSL v 3.0.0 through v.3.0.6  (github_poc): https://github.com/corelight/CVE-2022-3602
- https://github.com/cybersecurityworks553/CVE-2022-3602-and-CVE-2022-3786 (github_poc): https://github.com/cybersecurityworks553/CVE-2022-3602-and-CVE-2022-3786

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3602 and fix it if it is affected.

What it is: CVE-2022-3602 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3602 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.11
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.11
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.11
- node (Bitnami): affected from 18.0.0; fixed in 18.11.0, 18.12.1, 19.0.1
- node-min (Bitnami): affected from 18.0.0; fixed in 18.11.0, 18.12.1, 19.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3602/ (Markdown: https://insights.sbomify.com/CVE-2022-3602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3602
- OSV: https://osv.dev/vulnerability/CVE-2022-3602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3602/
Summaries are generated and may contain mistakes; the official description above is the record.
