CVE-2022-36023 Remote denial of service in Hyperledger Fabric Gateway

High 7.0 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2022-36023?

CVE-2022-36023 is a high-severity vulnerability in hyperledger fabric, published on 18 Aug 2022.

Official description

Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.

Weakness: CWE-20

Which versions are affected by CVE-2022-36023?

5 open source packages ship an affected version, including github.com/hyperledger/fabric, hyperledger-fabric-orderer and hyperledger-fabric-peer. It affects 1 product.

PackageAffectedFixed in
github.com/hyperledger/fabric GoFrom 2.4.02.4.6
github.com/hyperledger/fabric GoFrom 2.4.02.4.6
hyperledger-fabric-orderer BitnamiAll versions2.4.6
hyperledger-fabric-peer BitnamiAll versions2.4.6
hyperledger-fabric-tools BitnamiAll versions2.4.6

Products include Hyperledger Fabric.

How do I fix CVE-2022-36023?

Upgrade github.com/hyperledger/fabric to 2.4.6 or later.

Is CVE-2022-36023 being exploited?

There is no known exploitation of CVE-2022-36023 in the wild and no public exploit code.

Sources

Also known as BIT-hyperledger-fabric-orderer-2022-36023, BIT-hyperledger-fabric-peer-2022-36023, BIT-hyperledger-fabric-tools-2022-36023, GHSA-qj6r-fhrc-jj5r.

Is CVE-2022-36023 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free