{"answers":{"affected":"5 open source packages ship an affected version, including github.com/hyperledger/fabric, hyperledger-fabric-orderer and hyperledger-fabric-peer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36023 in the wild and no public exploit code.","fix":"Upgrade github.com/hyperledger/fabric to 2.4.6 or later.","what":"CVE-2022-36023 is a high-severity vulnerability in hyperledger fabric, published on 18 Aug 2022."},"fix_prompt":"Check this codebase for CVE-2022-36023 and fix it if it is affected.\n\nWhat it is: CVE-2022-36023 is a high-severity vulnerability in hyperledger fabric, published on 18 Aug 2022. \nExploitation: There is no known exploitation of CVE-2022-36023 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/hyperledger/fabric (Go): affected from 2.4.0; fixed in 2.4.6\n- github.com/hyperledger/fabric (Go): affected from 2.4.0; fixed in 2.4.6\n- hyperledger-fabric-orderer (Bitnami): affected all versions; fixed in 2.4.6\n- hyperledger-fabric-peer (Bitnami): affected all versions; fixed in 2.4.6\n- hyperledger-fabric-tools (Bitnami): affected all versions; fixed in 2.4.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36023/ (Markdown: https://insights.sbomify.com/CVE-2022-36023/index.md)","id":"CVE-2022-36023","markdown":"https://insights.sbomify.com/CVE-2022-36023/index.md","name":"CVE-2022-36023","record":{"aliases":["BIT-hyperledger-fabric-orderer-2022-36023","BIT-hyperledger-fabric-peer-2022-36023","BIT-hyperledger-fabric-tools-2022-36023","GHSA-qj6r-fhrc-jj5r"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"fabric","vendor":"hyperledger"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote denial of service in Hyperledger Fabric Gateway","id":"CVE-2022-36023","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2022"},"n_packages":5,"n_references":5,"next":{"headline":"Bots using py-cord as discord api wrapper are vulnerable to shutdowns through remote code execution","id":"CVE-2022-36024"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.6"],"introduced":["0"],"last_affected":[],"package":"hyperledger-fabric-orderer","purl":"pkg:bitnami/hyperledger-fabric-orderer","source":"BIT-hyperledger-fabric-orderer-2022-36023"},{"ecosystem":"Bitnami","fixed":["2.4.6"],"introduced":["0"],"last_affected":[],"package":"hyperledger-fabric-peer","purl":"pkg:bitnami/hyperledger-fabric-peer","source":"BIT-hyperledger-fabric-peer-2022-36023"},{"ecosystem":"Bitnami","fixed":["2.4.6"],"introduced":["0"],"last_affected":[],"package":"hyperledger-fabric-tools","purl":"pkg:bitnami/hyperledger-fabric-tools","source":"BIT-hyperledger-fabric-tools-2022-36023"},{"ecosystem":"Go","fixed":["2.4.6"],"introduced":["2.4.0"],"last_affected":[],"package":"github.com/hyperledger/fabric","purl":null,"source":"GHSA-qj6r-fhrc-jj5r"},{"ecosystem":"Go","fixed":["2.4.6"],"introduced":["2.4.0"],"last_affected":[],"package":"github.com/hyperledger/fabric","purl":"pkg:golang/github.com/hyperledger/fabric","source":"GHSA-qj6r-fhrc-jj5r"}],"prev":{"headline":"Some Deeplearning4J packages use unclaimed s3 bucket in tests and examples","id":"CVE-2022-36022"},"products":["fabric"],"published":"2022-08-18","related":[{"cvss_score":9.3,"headline":"ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE","id":"CVE-2026-41586","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2022-45196","kev_date_added":null,"published":"2022-11-12"},{"cvss_score":7.5,"headline":"Improper Input Validation in fabric hyperledger","id":"CVE-2022-31121","kev_date_added":null,"published":"2022-07-07"},{"cvss_score":7.1,"headline":"Crosslinking transaction attack in hyperledger/fabric","id":"CVE-2023-46132","kev_date_added":null,"published":"2023-11-14"},{"cvss_score":5.3,"headline":"Hyperledger Fabric does not verify request has a timestamp within the expected time window","id":"CVE-2024-45244","kev_date_added":null,"published":"2024-08-25"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["hyperledger"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-36023/"}