{"answers":{"affected":"3 open source packages ship an affected version, including py-cord. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36024 in the wild and no public exploit code.","fix":"Upgrade py-cord to 2.0.1 or later.","what":"CVE-2022-36024 is a high-severity missing authorization vulnerability in Pycord-Development pycord, published on 18 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36024 and fix it if it is affected.\n\nWhat it is: CVE-2022-36024 is a high-severity missing authorization vulnerability in Pycord-Development pycord, published on 18 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36024 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- py-cord (PyPI): affected from 2.0.0; fixed in 2.0.1\n- py-cord (PyPI): affected from 2.0.0; fixed in 2.0.1\n- py-cord (PyPI): affected from 2.0.0; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36024/ (Markdown: https://insights.sbomify.com/CVE-2022-36024/index.md)","id":"CVE-2022-36024","markdown":"https://insights.sbomify.com/CVE-2022-36024/index.md","name":"CVE-2022-36024","record":{"aliases":["GHSA-qmhj-m29v-gvmr","PYSEC-2022-43146"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Python Discord API wrapper","requires_auth":"none","summary":"Attackers can shut down Discord bots by exploiting missing authorization checks when the bot is added with specific scopes.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pycord","vendor":"pycord_development"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"py-cord is a an API wrapper for Discord written in Python. Bots creating using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the `application.commands` scope without the `bot` scope. Currently, it appears that all public bots that use slash commands are affected. This issue has been patched in version 2.0.1. There are currently no recommended workarounds - please upgrade to a patched version.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Bots using py-cord as discord api wrapper are vulnerable to shutdowns through remote code execution","id":"CVE-2022-36024","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Incorrect Conversion between Numeric Types in Besu Ethereum Client","id":"CVE-2022-36025"},"packages":[{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"py-cord","purl":null,"source":"GHSA-qmhj-m29v-gvmr"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"py-cord","purl":"pkg:pypi/py-cord","source":"GHSA-qmhj-m29v-gvmr"},{"ecosystem":"PyPI","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"py-cord","purl":"pkg:pypi/py-cord","source":"PYSEC-2022-43146"}],"prev":{"headline":"Remote denial of service in Hyperledger Fabric Gateway","id":"CVE-2022-36023"},"products":["pycord"],"published":"2022-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["Pycord-Development"]},"summary":"Attackers can shut down Discord bots by exploiting missing authorization checks when the bot is added with specific scopes.","url":"https://insights.sbomify.com/CVE-2022-36024/"}