# CVE-2022-36024: Bots using py-cord as discord api wrapper are vulnerable to shutdowns through remote code execution

> Attackers can shut down Discord bots by exploiting missing authorization checks when the bot is added with specific scopes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-qmhj-m29v-gvmr, PYSEC-2022-43146

## What is CVE-2022-36024?

CVE-2022-36024 is a high-severity missing authorization vulnerability in Pycord-Development pycord, published on 18 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

py-cord is a an API wrapper for Discord written in Python. Bots creating using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the `application.commands` scope without the `bot` scope. Currently, it appears that all public bots that use slash commands are affected. This issue has been patched in version 2.0.1. There are currently no recommended workarounds - please upgrade to a patched version.

Weakness: CWE-862 (Missing Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2022-36024?

3 open source packages ship an affected version, including py-cord. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `py-cord` | PyPI | From 2.0.0 | 2.0.1 |
| `py-cord` | PyPI | From 2.0.0 | 2.0.1 |
| `py-cord` | PyPI | From 2.0.0 | 2.0.1 |

Products: Pycord Development Pycord.

## How do I fix CVE-2022-36024?

Upgrade py-cord to 2.0.1 or later.

## Is CVE-2022-36024 being exploited?

There is no known exploitation of CVE-2022-36024 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36024 and fix it if it is affected.

What it is: CVE-2022-36024 is a high-severity missing authorization vulnerability in Pycord-Development pycord, published on 18 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36024 in the wild and no public exploit code.

Affected packages and fixed versions:
- py-cord (PyPI): affected from 2.0.0; fixed in 2.0.1
- py-cord (PyPI): affected from 2.0.0; fixed in 2.0.1
- py-cord (PyPI): affected from 2.0.0; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36024/ (Markdown: https://insights.sbomify.com/CVE-2022-36024/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36024
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36024
- OSV: https://osv.dev/vulnerability/CVE-2022-36024

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36024/
Summaries are generated and may contain mistakes; the official description above is the record.
