{"answers":{"affected":"2 open source packages ship an affected version, including nitrado.js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36034 in the wild and no public exploit code.","fix":"Upgrade nitrado.js to 0.2.5 or later.","what":"CVE-2022-36034 is a high-severity denial of service vulnerability in cainthebest nitrado.js, published on 29 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36034 and fix it if it is affected.\n\nWhat it is: CVE-2022-36034 is a high-severity denial of service vulnerability in cainthebest nitrado.js, published on 29 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36034 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nitrado.js (npm): affected all versions; fixed in 0.2.5\n- nitrado.js (npm): affected all versions; fixed in 0.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36034/ (Markdown: https://insights.sbomify.com/CVE-2022-36034/index.md)","id":"CVE-2022-36034","markdown":"https://insights.sbomify.com/CVE-2022-36034/index.md","name":"CVE-2022-36034","record":{"aliases":["GHSA-vqc4-v8hc-h2jg"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Nitrado API wrapper","requires_auth":"none","summary":"Attackers can cause denial of service in nitrado.js by supplying crafted input that triggers excessive regular expression backtracking.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"nitrado.js","vendor":"nitrado.js_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"nitrado.js is a type safe wrapper for the Nitrado API. Possible ReDoS with lib input of `{{` and with many repetitions of `{{|`. This issue has been patched in all versions above `0.2.5`. There are currently no known workarounds.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Possible Regular Expression Denial of Service (ReDoS) used on uncontrolled data in nitrado.js","id":"CVE-2022-36034","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Flux CLI Workload Injection","id":"CVE-2022-36035"},"packages":[{"ecosystem":"npm","fixed":["0.2.5"],"introduced":["0"],"last_affected":[],"package":"nitrado.js","purl":null,"source":"GHSA-vqc4-v8hc-h2jg"},{"ecosystem":"npm","fixed":["0.2.5"],"introduced":["0"],"last_affected":[],"package":"nitrado.js","purl":"pkg:npm/nitrado.js","source":"GHSA-vqc4-v8hc-h2jg"}],"prev":{"headline":"jsoup may not sanitize Cross-Site Scripting (XSS) attempts if SafeList.preserveRelativeLinks is enabled","id":"CVE-2022-36033"},"products":["nitrado.js"],"published":"2022-08-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["cainthebest"]},"summary":"Attackers can cause denial of service in nitrado.js by supplying crafted input that triggers excessive regular expression backtracking.","url":"https://insights.sbomify.com/CVE-2022-36034/"}