# CVE-2022-36034: Possible Regular Expression Denial of Service (ReDoS) used on uncontrolled data in nitrado.js

> Attackers can cause denial of service in nitrado.js by supplying crafted input that triggers excessive regular expression backtracking.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-vqc4-v8hc-h2jg

## What is CVE-2022-36034?

CVE-2022-36034 is a high-severity denial of service vulnerability in cainthebest nitrado.js, published on 29 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nitrado.js is a type safe wrapper for the Nitrado API. Possible ReDoS with lib input of `{{` and with many repetitions of `{{|`. This issue has been patched in all versions above `0.2.5`. There are currently no known workarounds.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-36034?

2 open source packages ship an affected version, including nitrado.js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nitrado.js` | npm | All versions | 0.2.5 |
| `nitrado.js` | npm | All versions | 0.2.5 |

Products: Nitrado.js Project Nitrado.js.

## How do I fix CVE-2022-36034?

Upgrade nitrado.js to 0.2.5 or later.

## Is CVE-2022-36034 being exploited?

There is no known exploitation of CVE-2022-36034 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36034 and fix it if it is affected.

What it is: CVE-2022-36034 is a high-severity denial of service vulnerability in cainthebest nitrado.js, published on 29 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36034 in the wild and no public exploit code.

Affected packages and fixed versions:
- nitrado.js (npm): affected all versions; fixed in 0.2.5
- nitrado.js (npm): affected all versions; fixed in 0.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36034/ (Markdown: https://insights.sbomify.com/CVE-2022-36034/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36034
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36034
- OSV: https://osv.dev/vulnerability/CVE-2022-36034

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36034/
Summaries are generated and may contain mistakes; the official description above is the record.
