# CVE-2022-36035: Flux CLI Workload Injection

> Attackers can inject arbitrary content into Kubernetes deployments via path traversal in Flux CLI, potentially leading to code execution or privilege escalation.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-flux-2022-36035, GHSA-xwf3-6rgv-939r, GO-2022-0960

## What is CVE-2022-36035?

CVE-2022-36035 is a high-severity path traversal vulnerability in fluxcd flux2, published on 31 Aug 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Flux is a tool for keeping Kubernetes clusters in sync with sources of configuration (like Git repositories), and automating updates to configuration when there is new code to deploy. Flux CLI allows users to deploy Flux components into a Kubernetes cluster via command-line. The vulnerability allows other applications to replace the Flux deployment information with arbitrary content which is deployed into the target Kubernetes cluster instead. The vulnerability is due to the improper handling of user-supplied input, which results in a path traversal that can be controlled by the attacker. Users sharing the same shell between other applications and the Flux CLI commands could be affected by this vulnerability. In some scenarios no errors may be presented, which may cause end users not to realize that something is amiss. A safe workaround is to execute Flux CLI in ephemeral and isolated shell environments, which can ensure no persistent values exist from previous processes. However, upgrading to the latest version of the CLI is still the recommended mitigation strategy.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-36035?

4 open source packages ship an affected version, including github.com/fluxcd/flux2 and flux. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fluxcd/flux2` | Go | From 0.21.0 | 0.32.0 |
| `github.com/fluxcd/flux2` | Go | From 0.21.0 | 0.32.0 |
| `github.com/fluxcd/flux2` | Go | From 0.21.0 | 0.32.0 |
| `flux` | Bitnami | From 0.21.0 | 0.32.0 |

Products: Fluxcd Flux2.

## How do I fix CVE-2022-36035?

Upgrade github.com/fluxcd/flux2 to 0.32.0 or later.

## Is CVE-2022-36035 being exploited?

There is no known exploitation of CVE-2022-36035 in the wild and no public exploit code.

## Other vulnerabilities in fluxcd flux2

- [CVE-2022-24817](https://insights.sbomify.com/CVE-2022-24817/): Improper kubeconfig validation allows arbitrary code execution (critical 9.9)
- [CVE-2022-24877](https://insights.sbomify.com/CVE-2022-24877/): Improper path handling in kustomization files allows path traversal (critical 9.9)
- [CVE-2022-36049](https://insights.sbomify.com/CVE-2022-36049/): Flux2 Helm Controller denial of service (high 7.7)
- [CVE-2022-24878](https://insights.sbomify.com/CVE-2022-24878/): Improper path handling in Kustomization files allows for denial of service (high 7.7)
- [CVE-2022-39272](https://insights.sbomify.com/CVE-2022-39272/): Flux2 vulnerable to Denial of Service due to Improper use of metav1.Duration (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36035 and fix it if it is affected.

What it is: CVE-2022-36035 is a high-severity path traversal vulnerability in fluxcd flux2, published on 31 Aug 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-36035 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fluxcd/flux2 (Go): affected from 0.21.0; fixed in 0.32.0
- github.com/fluxcd/flux2 (Go): affected from 0.21.0; fixed in 0.32.0
- github.com/fluxcd/flux2 (Go): affected from 0.21.0; fixed in 0.32.0
- flux (Bitnami): affected from 0.21.0; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36035/ (Markdown: https://insights.sbomify.com/CVE-2022-36035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36035
- OSV: https://osv.dev/vulnerability/CVE-2022-36035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36035/
Summaries are generated and may contain mistakes; the official description above is the record.
