{"answers":{"affected":"4 open source packages ship an affected version, including mdx-mermaid. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36036 exists.","fix":"Upgrade mdx-mermaid to a fixed version for your release line: 1.3.0 or 2.0.0-rc2.","what":"CVE-2022-36036 is a low-severity code injection vulnerability in sjwall mdx-mermaid, published on 29 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36036 and fix it if it is affected.\n\nWhat it is: CVE-2022-36036 is a low-severity code injection vulnerability in sjwall mdx-mermaid, published on 29 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36036 exists.\n\nAffected packages and fixed versions:\n- mdx-mermaid (npm): affected all versions; fixed in 1.3.0\n- mdx-mermaid (npm): affected all versions; fixed in 1.3.0\n- mdx-mermaid (npm): affected from 2.0.0-rc1; fixed in 2.0.0-rc2\n- mdx-mermaid (npm): affected from 2.0.0-rc1; fixed in 2.0.0-rc2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36036/ (Markdown: https://insights.sbomify.com/CVE-2022-36036/index.md)","id":"CVE-2022-36036","markdown":"https://insights.sbomify.com/CVE-2022-36036/index.md","name":"CVE-2022-36036","record":{"aliases":["GHSA-rvgm-35jw-q628"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"MDX Mermaid plugin","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary JavaScript by modifying Mermaid code blocks in MDX files, affecting users of the mdx-mermaid library.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mdx-mermaid","vendor":"mdx-mermaid_project"}],"cvss":{"score":3.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"mdx-mermaid provides plug and play access to Mermaid in MDX. There is a potential for an arbitrary javascript injection in versions less than 1.3.0 and 2.0.0-rc1. Modify any mermaid code blocks with arbitrary code and it will execute when the component is loaded by MDXjs. This vulnerability was patched in version(s) 1.3.0 and 2.0.0-rc2. There are currently no known workarounds.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper Control of Generation of Code ('Code Injection') in mdx-mermaid","id":"CVE-2022-36036","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":4,"n_references":2,"next":{"headline":"Cross-site scripting (XSS) from dynamic options in the multiselect field in Kirby","id":"CVE-2022-36037"},"packages":[{"ecosystem":"npm","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"mdx-mermaid","purl":null,"source":"GHSA-rvgm-35jw-q628"},{"ecosystem":"npm","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"mdx-mermaid","purl":"pkg:npm/mdx-mermaid","source":"GHSA-rvgm-35jw-q628"},{"ecosystem":"npm","fixed":["2.0.0-rc2"],"introduced":["2.0.0-rc1"],"last_affected":[],"package":"mdx-mermaid","purl":null,"source":"GHSA-rvgm-35jw-q628"},{"ecosystem":"npm","fixed":["2.0.0-rc2"],"introduced":["2.0.0-rc1"],"last_affected":[],"package":"mdx-mermaid","purl":"pkg:npm/mdx-mermaid","source":"GHSA-rvgm-35jw-q628"}],"prev":{"headline":"Flux CLI Workload Injection","id":"CVE-2022-36035"},"products":["mdx-mermaid"],"published":"2022-08-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["sjwall"]},"summary":"Attackers can execute arbitrary JavaScript by modifying Mermaid code blocks in MDX files, affecting users of the mdx-mermaid library.","url":"https://insights.sbomify.com/CVE-2022-36036/"}