# CVE-2022-36036: Improper Control of Generation of Code ('Code Injection') in mdx-mermaid

> Attackers can execute arbitrary JavaScript by modifying Mermaid code blocks in MDX files, affecting users of the mdx-mermaid library.

- **Severity:** Low 3.6 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-rvgm-35jw-q628

## What is CVE-2022-36036?

CVE-2022-36036 is a low-severity code injection vulnerability in sjwall mdx-mermaid, published on 29 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

mdx-mermaid provides plug and play access to Mermaid in MDX. There is a potential for an arbitrary javascript injection in versions less than 1.3.0 and 2.0.0-rc1. Modify any mermaid code blocks with arbitrary code and it will execute when the component is loaded by MDXjs. This vulnerability was patched in version(s) 1.3.0 and 2.0.0-rc2. There are currently no known workarounds.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-36036?

4 open source packages ship an affected version, including mdx-mermaid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mdx-mermaid` | npm | All versions | 1.3.0 |
| `mdx-mermaid` | npm | All versions | 1.3.0 |
| `mdx-mermaid` | npm | From 2.0.0-rc1 | 2.0.0-rc2 |
| `mdx-mermaid` | npm | From 2.0.0-rc1 | 2.0.0-rc2 |

Products: Mdx-Mermaid Project Mdx-Mermaid.

## How do I fix CVE-2022-36036?

Upgrade mdx-mermaid to a fixed version for your release line: 1.3.0 or 2.0.0-rc2.

## Is CVE-2022-36036 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36036 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36036 and fix it if it is affected.

What it is: CVE-2022-36036 is a low-severity code injection vulnerability in sjwall mdx-mermaid, published on 29 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-36036 exists.

Affected packages and fixed versions:
- mdx-mermaid (npm): affected all versions; fixed in 1.3.0
- mdx-mermaid (npm): affected all versions; fixed in 1.3.0
- mdx-mermaid (npm): affected from 2.0.0-rc1; fixed in 2.0.0-rc2
- mdx-mermaid (npm): affected from 2.0.0-rc1; fixed in 2.0.0-rc2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36036/ (Markdown: https://insights.sbomify.com/CVE-2022-36036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36036
- OSV: https://osv.dev/vulnerability/CVE-2022-36036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36036/
Summaries are generated and may contain mistakes; the official description above is the record.
