{"answers":{"affected":"2 open source packages ship an affected version, including getkirby/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36037 in the wild and no public exploit code.","fix":"Upgrade getkirby/cms to 3.5.8.1 or later.","what":"CVE-2022-36037 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 29 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36037 and fix it if it is affected.\n\nWhat it is: CVE-2022-36037 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 29 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36037 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- getkirby/cms (Packagist): affected all versions; fixed in 3.5.8.1\n- getkirby/cms (Packagist): affected all versions; fixed in 3.5.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36037/ (Markdown: https://insights.sbomify.com/CVE-2022-36037/index.md)","id":"CVE-2022-36037","markdown":"https://insights.sbomify.com/CVE-2022-36037/index.md","name":"CVE-2022-36037","record":{"aliases":["GHSA-3f89-869f-5w76"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"Kirby CMS","requires_auth":"low_privilege","summary":"Attackers with influence on multiselect options can inject malicious HTML/JavaScript, leading to code execution and privilege escalation in the Kirby Panel.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kirby","vendor":"getkirby"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"kirby is a content management system (CMS) that adapts to many different projects and helps you build your own ideal interface. Cross-site scripting (XSS) is a type of vulnerability that allows execution of any kind of JavaScript code inside the Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim. If bad actors gain access to your group of authenticated Panel users they can escalate their privileges via the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible. The multiselect field allows selection of tags from an autocompleted list. Unfortunately, the Panel in Kirby 3.5 used HTML rendering for the raw option value. This allowed **attackers with influence on the options source** to store HTML code. The browser of the victim who visited a page with manipulated multiselect options in the Panel will then have rendered this malicious HTML code when the victim opened the autocomplete dropdown. Users are *not* affected by this vulnerability if you don't use the multiselect field or don't use it with options that can be manipulated by attackers. The problem has been patched in Kirby 3.5.8.1.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting (XSS) from dynamic options in the multiselect field in Kirby","id":"CVE-2022-36037","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"CircuitVerse potential RCE vulnerability via Oj.load","id":"CVE-2022-36038"},"packages":[{"ecosystem":"Packagist","fixed":["3.5.8.1"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":null,"source":"GHSA-3f89-869f-5w76"},{"ecosystem":"Packagist","fixed":["3.5.8.1"],"introduced":["0"],"last_affected":[],"package":"getkirby/cms","purl":"pkg:composer/getkirby/cms","source":"GHSA-3f89-869f-5w76"}],"prev":{"headline":"Improper Control of Generation of Code ('Code Injection') in mdx-mermaid","id":"CVE-2022-36036"},"products":["kirby"],"published":"2022-08-29","related":[{"cvss_score":8.8,"headline":"Kirby vulnerable to unrestricted file upload of user avatar images","id":"CVE-2024-26483","kev_date_added":null,"published":"2024-02-22"},{"cvss_score":8.1,"headline":"Insufficient permission checks in the language settings in Kirby CMS","id":"CVE-2024-41964","kev_date_added":null,"published":"2024-08-29"},{"cvss_score":7.6,"headline":"Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering","id":"CVE-2026-34587","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":7.6,"headline":"Cross-site scripting (XSS) from unsanitized uploaded SVG files","id":"CVE-2021-29460","kev_date_added":null,"published":"2021-04-27"},{"cvss_score":7.3,"headline":"Kirby vulnerable to Insufficient Session Expiration after a password change","id":"CVE-2023-38489","kev_date_added":null,"published":"2023-07-27"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from writer field content in the site frontend","id":"CVE-2021-41252","kev_date_added":null,"published":"2021-11-16"},{"cvss_score":7.3,"headline":"Cross-site scripting (XSS) from image block content in the site frontend","id":"CVE-2021-41258","kev_date_added":null,"published":"2021-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["getkirby"]},"summary":"Attackers with influence on multiselect options can inject malicious HTML/JavaScript, leading to code execution and privilege escalation in the Kirby Panel.","url":"https://insights.sbomify.com/CVE-2022-36037/"}